Author Topic: i installed letsencrypt without www now with www browser says bad certificate  (Read 13731 times)

0 Members and 1 Guest are viewing this topic.

i installed letsencrypt without www now when i visit my website with from browser it says bad certificate

how do i edit this to fix is there a way i can edit this or delete certificate and add certificate again by checkmarking www

i edited letsencrypt configuaration by adding www in the end

uninstall letsencrypt and install it again then try to issue the certs with www checkbox enabled

I had same, forgot also to tick the www, but I can't find out hw to delete the ssl to generate again with the www. can any one give some directions in how to do this?  Thanks.

you need to manually remove the certs or uninstall LE and reinstall


For anyone coming here, the easiest way is to remove the entries and the files/folders.

Remove codeblock for domain [vhost....:

Remove the row with the domain in:

Remove folders:

Don't restart Apache, go straight back in Letsencrypt and issue again, this time tick the box WWW  :-)

check for proper working
« Last Edit: February 14, 2017, 04:48:52 PM by TheRavenKing »

the easiest way is to click on right box of letsencrypt where it shows 2 links and add single line to it for adding www and it works.

note : you can get the single line of www by adding new ssl to another domain by checkmarking www and it will show the new line in right box one of 2 configuaration files.

It is the easiest one.

@ahmed, can you give more step by step details I just can't find what you try to explain, sorry.

In menu click on apache settings


click on letsencrypt manager


on right side in a box on a page which opened when you clicked on letsencrypt manager just look for

Letsencrypt Configuration
Configuration files:
- CWP Configuration
- Apache Configuration

* Still under beta, report any issue here.

then click on - CWP Configuration

and you will find line like

just add in the line

Save and visit your website

make sure you added redirect to https:// in vhosts

Thank you,  yes I tried that, but it didn't work out for me, hence I came with other solution.

This is an example of the code block (replace USERNAME YOUR_DOMAIN, YOUR_SERVER_IP accordingly)

# vhost_start
<VirtualHost YOUR_SERVER_IP:443>
 DocumentRoot /home/USERNAME/public_html
 SSLEngine on
 SSLProtocol All -SSLv2 -SSLv3

# SSLCertificateFile /etc/pki/tls/certs/
#SSLCertificateKeyFile /etc/pki/tls/private/
# SSLCertificateChainFile /etc/pki/tls/certs/

##Prevent Warning of Browser
SSLCertificateFile /etc/letsencrypt/live/
SSLCertificateKeyFile /etc/letsencrypt/live/
SSLCertificateChainFile /etc/letsencrypt/live/
 SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
<IfModule mod_suexec.c>

<IfModule mod_suphp.c>
    suPHP_ConfigPath /home/USERNAME

<Directory "/home/USERNAME/public_html">
    AllowOverride All
# vhost_end

As you can see , ##Prevent Warning of Browser. This is a quick fix to get risk of warning from browser
Make sure these files are exist:
« Last Edit: February 24, 2017, 07:35:42 AM by locvfx »