Author Topic: named failed  (Read 10594 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
named failed
« on: October 14, 2014, 04:30:45 AM »
I'm getting the following error when restarting named. How can I get the DNS server running again?

Code: [Select]
Starting named:
Error in named configuration:
zone localhost.localdomain/IN: loaded serial 0
zone localhost/IN: loaded serial 0
zone 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: loaded serial 0
zone 1.0.0.127.in-addr.arpa/IN: loaded serial 0
zone 0.in-addr.arpa/IN: loaded serial 0
zone cool-teens.net/IN: loaded serial 2013071600
zone pornfreaknation.com/IN: loaded serial 2013071600
dns_rdata_fromtext: /var/named/scornmovie.com.db:4: near '****@gmail.com.': bad name (check-names)
zone scornmovie.com/IN: loading from master file /var/named/scornmovie.com.db failed: bad name (check-names)
zone scornmovie.com/IN: not loaded due to errors.
_default/scornmovie.com/IN: bad name (check-names)
zone mspowderhorns.com/IN: loaded serial 2013071600
dns_rdata_fromtext: /var/named/hochparterre-schweiz.ch.db:4: near '****@gmail.com.': bad name (check-names)
zone hochparterre-schweiz.ch/IN: loading from master file /var/named/hochparterre-schweiz.ch.db failed: bad name (check-names)
zone hochparterre-schweiz.ch/IN: not loaded due to errors.
_default/hochparterre-schweiz.ch/IN: bad name (check-names)
[FAILED]

Offline
*
Re: named failed
« Reply #1 on: October 14, 2014, 06:53:48 PM »
looks like an issue with email address in your dns zones,
you will need to check them and make correction.
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
***
Re: named failed
« Reply #2 on: October 15, 2014, 03:19:07 AM »
I bet for that  ;D http://ben.goodacre.name/tech/Bad_owner_name_(check-names)_Error_(BIND) even if it's dated on 2008.

If the error is the email, must be A underscore => near '****@gmail.com.': bad name (check-names)
I gues email is like sometingh_****@gmail.com so only 4 (*) are displayed.

When you read "near" is usually just the last character before the output string.
I've read a lot of errors like that using Mysql when you put a wron sintax.

Solution 1: Use another email.


Solution 2: turn off name checking From http://www.novell.com/support/kb/doc.php?id=7001908

BIND include a "check-name" option to remove name checking for DNS names, records and zones. In your named.conf (traditionally in /etc), place the following:
Code: [Select]
check-names master ignore;
check-names slave ignore;
check-names response ignore;

Regards.
« Last Edit: October 15, 2014, 03:24:29 AM by erm3nda »
8==D it's a function that try to compare 8 (int) against D (string) which returns True or False depending on the asker.