Author Topic: CentOS6 Upgrade  (Read 258978 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
Re: CentOS6 Upgrade
« Reply #60 on: March 24, 2017, 08:16:43 AM »
Thanks to Sandeep we found the issue about mysql import, cant import locally db, but it is possible from other PC, network, developers know about that issue and will fix that I hope in next update (only some servers have this issue).

About ModSecurty, I think it is also an issue, that it locks down apache when restarting or stoping it when ModSecurity is enabled... Solution - need to uninstall ModSecurity to fix apache, after uninstall apache start or restart works (in my case).

Admin, please post here new fixes and info to let ohers know that there is a problem and it will be fixed.

Tranks

Offline
*
Re: CentOS6 Upgrade
« Reply #61 on: March 24, 2017, 02:51:05 PM »
yeaah.. it's already fixed and good work for the team..
CWP is the best free linux control panel I've used, and you guys don't forget to donate for the hard work CWP developers.
Thanks anyway..

Offline
**
Re: CentOS6 Upgrade
« Reply #62 on: March 24, 2017, 07:09:49 PM »
No fix for uploading the mysql db, problem also loading from local pc....  ::)

Offline
*
Re: CentOS6 Upgrade
« Reply #63 on: March 25, 2017, 03:44:12 PM »
No fix for uploading the mysql db, problem also loading from local pc....  ::)

Hi, destroy your server and try to fresh install with centos 7 (CWP7).
CWP7 is updated and fixed mysql bugs.

Offline
*
Re: CentOS6 Upgrade
« Reply #64 on: March 27, 2017, 08:05:27 AM »
Have noticed few bugs too:

This is what I got in email when auto update cron works...

Code: [Select]
/etc/cron.daily/cwp:

PHP Fatal error: 
The file /usr/local/cwpsrv/htdocs/resources/admin/include/cron.php was encoded with the PHP 5.6 ionCube Encoder and requires PHP 5.6 to be installed.
 in Unknown on line 0
PHP Fatal error: 
The file /usr/local/cwpsrv/htdocs/resources/admin/include/cron_backup.php was encoded with the PHP 5.6 ionCube Encoder and requires PHP 5.6 to be installed.
 in Unknown on line 0

And there are some bugs when I try install php 7 from selector

Install dependencies:

Code: [Select]
--> Finished Dependency Resolution
Error: mysql55w-libs conflicts with mysql-libs-5.1.73-8.el6_8.x86_64
Error: mysql55w-devel conflicts with mysql-devel-5.1.73-8.el6_8.x86_64
Error: mysql55w conflicts with mysql-5.1.73-8.el6_8.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
mkdir: cannot create directory `/usr/kerberos': File exists
ln: creating symbolic link `/usr/kerberos/lib/lib64': File exists
ln: creating symbolic link `/usr/lib/libjpeg.so': File exists
ln: creating symbolic link `/usr/lib/libpng.so': File exists
ln: creating symbolic link `/usr/lib/libmysqlclient.so.16': File exists
ln: creating symbolic link `/usr/lib/libmysqlclient.so': File exists
ln: creating symbolic link `/usr/lib/libexpat.so': File exists

php compile errors:

Code: [Select]
Packages skipped because of dependency problems:
    mysql-5.1.73-8.el6_8.x86_64 from updates
    mysql-devel-5.1.73-8.el6_8.x86_64 from updates
    mysql-libs-5.1.73-8.el6_8.x86_64 from updates
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for apr which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of apr of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude apr.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of apr installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of apr installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: apr-1.3.9-5.el6_2.i686 != apr-1.5.2-2.x86_64
Error: Protected multilib versions: apr-util-1.3.9-3.el6_0.1.i686 != apr-util-1.5.4-2.x86_64
buildconf: checking installation...
buildconf: autoconf version 2.63 (ok)
rebuilding aclocal.m4
rebuilding configure
configure.ac:276: error: Autoconf version 2.64 or higher is required
build/ax_check_compile_flag.m4:60: AX_CHECK_COMPILE_FLAG is expanded from...
autom4te: /usr/bin/m4 failed with exit status: 63
rebuilding main/php_config.h.in
configure.ac:276: error: Autoconf version 2.64 or higher is required
build/ax_check_compile_flag.m4:60: AX_CHECK_COMPILE_FLAG is expanded from...
autom4te: /usr/bin/m4 failed with exit status: 63
autoheader: '/usr/bin/autom4te' failed with exit status: 63
/usr/local/cwp/.conf/php_conf/php7.conf: line 1: ./configure: No such file or directory
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `install'.  Stop.
Stopping httpd: [  OK  ]
Starting httpd: AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message
[  OK  ]

Build Completed


There are few bugs in Apache with some mods and ssl in configuration but fixed that. Don't know does anybody else have same issues I was working step by step from first post to update everything maybe something went wrong don't know...

Offline
*
Re: CentOS6 Upgrade
« Reply #65 on: March 27, 2017, 08:43:40 AM »
No fix for uploading the mysql db, problem also loading from local pc....  ::)

Hi, destroy your server and try to fresh install with centos 7 (CWP7).
CWP7 is updated and fixed mysql bugs.

I must use centos 6 on my old desktop, it won't let me install centos 7.


How to install CWP repo?
Found only this: http://repo.centos-webpanel.com/

This is my repolist:
Code: [Select]
repo id                        repo name                                  status
base                           CentOS-6 - Base                            6,696
centos-sclo-rh                 CentOS-6 - SCLo rh                         4,955
centos-sclo-sclo               CentOS-6 - SCLo sclo                         287
extras                         CentOS-6 - Extras                             64
mariadb                        MariaDB                                       17
midnight-commander             Midnight Commander (CentOS_6)                  5
rpmforge                       RHEL 6 - RPMforge.net - dag                4,718
updates                        CentOS-6 - Updates                           974

Code: [Select]
yum list installed|grep apr
apr.x86_64                           1.3.9-5.el6_2              @base
apr-devel.x86_64                     1.3.9-5.el6_2              @base
apr-util.x86_64                      1.3.9-3.el6_0.1            @base
apr-util-devel.x86_64                1.3.9-3.el6_0.1            @base
apr-util-ldap.x86_64                 1.3.9-3.el6_0.1            @base


Should I remove certain repo's?
Should I remove all apr related and install from CWP repo?
Hobby home server with CentOS 7 + CWP (NAT-ed Mod enabled).

Offline
*
Re: CentOS6 Upgrade
« Reply #66 on: March 28, 2017, 08:27:36 AM »
Hi All,

I just upgraded a server that had existing SSL certs from CWP 0.9.8.153 to CWP6 0.9.8.197 using the scripts provided by the OP.

All went well except Apache wouldn't start one completed. So I rebuild Apache via CWP, it still wouldn't start and was receiving an error that suggested a spelling error or unknown character on line 2 of  /usr/local/apache/conf.d/ssl.conf - I compared this file with CWP7 server I have and saw it was some missing some lines. Added them and Apache now starts and runs fine.

Lines I added to the ssl.conf file are listed below (first 3 lines in file) should anyone experience same error.

<IfModule !ssl_module>
LoadModule ssl_module modules/mod_ssl.so
</IfModule>

 :)
Web Design, Development & VPS Hosting
https://6sense.com.au

Offline
*
Re: CentOS6 Upgrade
« Reply #67 on: March 28, 2017, 08:30:34 AM »
yep mod ssl was not loaded after upgrade had same problem...

Offline
*
Re: CentOS6 Upgrade
« Reply #68 on: March 28, 2017, 08:37:06 AM »
Good morning guys!

I've a problem with mi installation of CWP6 when i tried to upgrade manually from version 0.9.8.153: i've followed all steps described in first post, but installation went wrong.

I've executed:
Code: [Select]
sh cwpsrv.sh restore
sh apache.sh restore
but now i've a problem:

- error 500 in phpMyAdmin and mySQL-based sites

this il my actual configuration (after restore):
Apache version: Apache/2.2.27
PHP version: 5.4.27 [PHP Switcher]
MySQL version: 5.5.54
CWP version: 0.9.8.153

how can i fix it?
return tu previus mysql version?

thanks in advice

« Last Edit: March 28, 2017, 09:04:54 AM by Evinrude »

Offline
*****
Re: CentOS6 Upgrade
« Reply #69 on: March 28, 2017, 04:39:59 PM »
Hi,

how can i fix it?
return tu previus mysql version?

thanks in advice

no need to touch MySQL server because it does not make sense in this case.
Check Apache error_log for some errors about "500 error"
« Last Edit: March 28, 2017, 04:44:33 PM by Igor S. »
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*****
Re: CentOS6 Upgrade
« Reply #70 on: March 28, 2017, 04:43:24 PM »
Hi,

How to install CWP repo?
Found only this: http://repo.centos-webpanel.com/

just add file /etc/yum.repos.d/cwp.repo with:
Code: [Select]
[cwp]
name=CentOS Web Panel repo for Linux 6 - $basearch
baseurl=http://repo.centos-webpanel.com/repo/6/$basearch
failovermethod=priority
enabled=1
gpgcheck=0
Do not forget delete apr-util-ldap
Code: [Select]
yum erase apr-util-ldap
« Last Edit: April 06, 2017, 08:27:50 AM by Administrator »
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*****
Re: CentOS6 Upgrade
« Reply #71 on: March 28, 2017, 04:46:35 PM »
Hi, all.
If you have the issue with mod_ssl which does not loaded try next command:
Code: [Select]
sed -i "s|^#LoadModule ssl_module modules.*$|LoadModule ssl_module modules/mod_ssl.so|" /usr/local/apache/conf/httpd.conf
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: CentOS6 Upgrade
« Reply #72 on: March 28, 2017, 07:31:44 PM »
Hi,

How to install CWP repo?
Found only this: http://repo.centos-webpanel.com/

just add file /etc/yum.repos.d/cwp.repo with:
Code: [Select]
[cwp]
name=CentOS Web Panel repo for Linux 6 - \$basearch
baseurl=http://repo.centos-webpanel.com/repo/6/\$basearch
failovermethod=priority
enabled=1
gpgcheck=0
Do not forget delete apr-util-ldap
Code: [Select]
yum erase apr-util-ldap

Thanks, got cwp.repo installed. Now I have latest apr. (from cwp.repo)

Ran into some trouble. apr-util-ldap was removed from httpd dependencies and caused httpd not to auto start at boot.
Fixed it with chkconfig httpd on
Hobby home server with CentOS 7 + CWP (NAT-ed Mod enabled).

Offline
*
Re: CentOS6 Upgrade
« Reply #73 on: March 28, 2017, 08:24:54 PM »
Hi,

how can i fix it?
return tu previus mysql version?

thanks in advice

no need to touch MySQL server because it does not make sense in this case.
Check Apache error_log for some errors about "500 error"

Hi Igor,
i found this:
Code: [Select]
(2)No such file or directory: couldn't create child process: /usr/local/sbin/suphp for /usr/local/apache/htdocs/phpMyAdmin/index.php
thanks

Offline
*****
Re: CentOS6 Upgrade
« Reply #74 on: March 29, 2017, 08:06:42 AM »
Hi,

Hi Igor,
i found this:
Code: [Select]
(2)No such file or directory: couldn't create child process: /usr/local/sbin/suphp for /usr/local/apache/htdocs/phpMyAdmin/index.phpthanks

Never seen it before. Looks like some individual trouble. And the path to the PMA is wrong for new CWP version
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services