Author Topic: CentOS6 Upgrade  (Read 195735 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Re: CentOS6 Upgrade
« Reply #90 on: April 06, 2017, 06:06:52 AM »
Must be 5.5 mysql version...

Offline
*
Re: CentOS6 Upgrade
« Reply #91 on: April 06, 2017, 07:29:40 AM »
Updating Apache causes problems

apache.sh: line 137: unexpected EOF while looking for matching ``'
apache.sh: line 146: unexpected token `▒' in conditional command
apache.sh: line 146: syntax error: unexpected end of file
[root@server src]#

Starting httpd: httpd: Syntax error on line 54 of /usr/local/apache/conf/httpd.conf: Cannot load modules/mod_antiloris.so into server: /usr/local/apache/modules/mod_antiloris.so: undefined symbol: ap_log_error
[FAILED]



Same here... after upgrade httpd can't start and got the error...

"Starting httpd: httpd: Syntax error on line 54 of /usr/local/apache/conf/httpd.conf: Cannot load modules/mod_antiloris.so into server: /usr/local/apache/modules/mod_antiloris.so: undefined symbol: ap_log_error"

Any help ?
Thanks

Offline
*
Re: CentOS6 Upgrade
« Reply #92 on: April 06, 2017, 07:30:50 AM »
delete line matching mod_antiloris.so from /usr/local/apache/conf/httpd.conf
you can use this command
Code: [Select]
sed -i '/mod_antiloris/d' /usr/local/apache/conf/httpd.conf
« Last Edit: April 06, 2017, 07:35:50 AM by Administrator »
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: CentOS6 Upgrade
« Reply #93 on: April 06, 2017, 07:34:50 AM »
Stopping httpd: [FAILED]
Starting httpd: httpd: Syntax error on line 430 of /usr/local/apache/conf/httpd.conf: Syntax error on line 1 of /usr/local/apache/conf.d/ssl.conf: module ssl_module is built-in and can't be loaded
[FAILED]

Offline
*
Re: CentOS6 Upgrade
« Reply #94 on: April 06, 2017, 10:32:58 AM »
delete that file and if you use ssl then just install ssl for any domain and it should be fixed.
Code: [Select]
rm -f /usr/local/apache/conf.d/ssl.conf
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: CentOS6 Upgrade
« Reply #95 on: April 06, 2017, 10:38:46 AM »
Thanks, it worked. After restarting, and adding cwpro

Warning: [obfuscated](): (HY000/2002): No such file or directory in /usr/local/cwpsrv/htdocs/admin/admin/index.php on line 0

Warning: [obfuscated](): (HY000/2002): No such file or directory in /usr/local/cwpsrv/htdocs/admin/admin/index.php on line 0
**Check your MySQL root password in: /usr/local/cwpsrv/htdocs/resources/admin/include/db_conn.php and /root/.my.cnf


Warning: [obfuscated]() expects exactly 1 parameter, 0 given in /usr/local/cwpsrv/htdocs/admin/admin/index.php on line 0
Could not connect:

And on the login page:2030/login.php 404 error
« Last Edit: April 06, 2017, 10:45:16 AM by ida »

Offline
*
Re: CentOS6 Upgrade
« Reply #96 on: April 06, 2017, 02:29:29 PM »
Hello,

The update was partially unsuccessful.

I had to restore a backup of my server because the CWP restore also did not work.

CWP update was successfull, but the apache not.

I have this for every domains and subdomains:

Forbidden
You don't have permission to access / on this server.

Apache with a lot "Internal Server Error" errors.

Offline
*
Re: CentOS6 Upgrade
« Reply #97 on: April 06, 2017, 05:09:25 PM »
another server..another problem... this is really a mess!!
mysql 5.6.30 was installed.. now when I ran the cwp update script..it shows this...

  inflating: phpMyAdmin-4.6.6-all-languages/themes/pmahomme/jquery/images/ui-icons_888888_256x240.png
  inflating: phpMyAdmin-4.6.6-all-languages/themes/pmahomme/jquery/images/ui-icons_cd0a0a_256x240.png
  inflating: phpMyAdmin-4.6.6-all-languages/themes/pmahomme/jquery/jquery-ui-1.11.4.css
  inflating: phpMyAdmin-4.6.6-all-languages/themes/pmahomme/layout.inc.php
 extracting: phpMyAdmin-4.6.6-all-languages/themes/pmahomme/screen.png
  inflating: phpMyAdmin-4.6.6-all-languages/themes/pmahomme/sprites.lib.php
  inflating: phpMyAdmin-4.6.6-all-languages/themes/sprites.css.php
  inflating: phpMyAdmin-4.6.6-all-languages/themes/svg_gradient.php
  inflating: phpMyAdmin-4.6.6-all-languages/transformation_overview.php
  inflating: phpMyAdmin-4.6.6-all-languages/transformation_wrapper.php
  inflating: phpMyAdmin-4.6.6-all-languages/url.php
  inflating: phpMyAdmin-4.6.6-all-languages/user_password.php
  inflating: phpMyAdmin-4.6.6-all-languages/version_check.php
  inflating: phpMyAdmin-4.6.6-all-languages/view_create.php
  inflating: phpMyAdmin-4.6.6-all-languages/view_operations.php

Seems like something went wrong
If you have problem with CWP try run cwpsrv.sh.1 restore

I Ran cwpsrv.sh.1 restore

Removed:
  cwpphp.x86_64 0:7.0.17-1               cwpsrv.x86_64 0:1.10.2-4

Complete!
Stopping cwpsrvd:                                          [FAILED]
Starting cwpsrvd: (98)Address already in use: make_sock: could not bind to address [::]:2030
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:2030
no listening sockets available, shutting down
Unable to open logs
                                                           [FAILED]

What now???
any ideas?

Offline
*
Re: CentOS6 Upgrade
« Reply #98 on: April 06, 2017, 06:15:14 PM »
Well.. Iīve got lucky..

As mentioned before, I couldnīt do a cwpserver restore after I tried to update my cwp 0.0.8.14 to newer version..
so after severall atempts to make it work.. I decide an extreme mesure..
made another backup of DDBB of my domains, and domains and copy on another directory..
then... I made a "clean" install using sh cwa-latest

It worked out! I thought I had to reinstall mysql and recreate domains and stuff.. but to my surprise..everything was there...
working..and with CWP version: 0.9.8.17 ! (i had 0.9.8.14)

guess Iīve been lucky..

 




Offline
*
Re: CentOS6 Upgrade
« Reply #99 on: April 06, 2017, 08:27:49 PM »
And on the login page:2030/login.php 404 error

new url is page:2030/index.php

Forbidden
You don't have permission to access / on this server.

Apache with a lot "Internal Server Error" errors.

You can check for all errors in the log files and rebuild vhosts or apache depending on the issue.


Stopping cwpsrvd:                                          [FAILED]
Starting cwpsrvd: (98)Address already in use: make_sock: could not bind to address [::]:2030
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:2030
no listening sockets available, shutting down
Unable to open logs
                                                           [FAILED]

What now???
any ideas?

have you tried to kill the process and/or do a simple reboot of the server ?

For all
All issues you are reporting can be done by running rebuild of the cwp-httpd and rebuild of the vhosts from cwp, all you need is to read logs.
http://wiki.centos-webpanel.com/service-log-paths
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: CentOS6 Upgrade
« Reply #100 on: April 06, 2017, 10:28:50 PM »
And on the login page:2030/login.php 404 error

Stopping cwpsrvd:                                          [FAILED]
Starting cwpsrvd: (98)Address already in use: make_sock: could not bind to address [::]:2030
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:2030
no listening sockets available, shutting down
Unable to open logs
                                                           [FAILED]

What now???
any ideas?

have you tried to kill the process and/or do a simple reboot of the server ?

Yes! i did it several times, but the pid for cwp was always running... only rebooting the server stoped it!

For all
All issues you are reporting can be done by running rebuild of the cwp-httpd and rebuild of the vhosts from cwp, all you need is to read logs.
http://wiki.centos-webpanel.com/service-log-paths

at that moment couldīt get cwp to work and all the sites where down logically.. tried restore and didn't work out..
thats why did a "clean" install..

Offline
**
Re: CentOS6 Upgrade
« Reply #101 on: April 07, 2017, 01:34:56 AM »
After running CWP Upgrade script I got this error:
Code: [Select]
Starting cwpsrv: cwpsrv: [emerg] SL_CTX_use_PrivateKey_file("/etc/pki/tls/private/hostname.key") failed (SSL: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch) [FAILED]
« Last Edit: April 07, 2017, 01:37:10 AM by Gogo »
GamePanel and TeamspeakManager Modules source codes are for SALE, PM me!

Offline
*
Re: CentOS6 Upgrade
« Reply #102 on: April 07, 2017, 06:17:08 AM »
Thanks Administrator, but i have always this error:

Warning: [obfuscated](): (HY000/2002): No such file or directory in /usr/local/cwpsrv/htdocs/admin/admin/index.php on line 0

Warning: [obfuscated](): (HY000/2002): No such file or directory in /usr/local/cwpsrv/htdocs/admin/admin/index.php on line 0
**Check your MySQL root password in: /usr/local/cwpsrv/htdocs/resources/admin/include/db_conn.php and /root/.my.cnf


Warning: [obfuscated]() expects exactly 1 parameter, 0 given in /usr/local/cwpsrv/htdocs/admin/admin/index.php on line 0
Could not connect:

Offline
*
Re: CentOS6 Upgrade
« Reply #103 on: April 07, 2017, 06:36:22 AM »
solved with:

service mysqld start

thanks.

Offline
*
Re: CentOS6 Upgrade
« Reply #104 on: April 07, 2017, 04:52:57 PM »
After fixing many issue I am only left with the https [letsencrypt] for the server not working.

All 3 ssl checkers say it is all fine, but I can't login with https.

Any one any ideas?

Thanks