Author Topic: CentOS6 Upgrade  (Read 207235 times)

0 Members and 1 Guest are viewing this topic.

Offline
*****
Re: CentOS6 Upgrade
« Reply #120 on: April 13, 2017, 09:57:50 AM »
When I access this link domain.com/webmail  I get the error  :
DATABASE ERROR: CONNECTION FAILED!

In new CWP link was changed. Try open webmail and PhpMyAdmin from CWP please.
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*****
Re: CentOS6 Upgrade
« Reply #121 on: April 13, 2017, 09:59:47 AM »
Hello.

I made the update after the warning that came up.
But unfortunately I encounter this error:

When I did my checks, I could not find an error in conf files.
I need urgent help.
The company's sites and mails are not working.  :(

Hi, upgrade has no affect with DNS. Check file  /var/named/www.sempatiotomasyon.com.db for errors
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*****
Re: CentOS6 Upgrade
« Reply #122 on: April 13, 2017, 10:01:15 AM »
I installed this morning manually  cwp-httpd and cwp-suphp >> Apache works again
in the Dashboard shows it now Apache 2.4.25 but when i check in PHP info it shows me 2.2.27 This ok ?

Hi, no it is not okay :) check
Code: [Select]
/usr/local/apache/bin/httpd -v
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: CentOS6 Upgrade
« Reply #123 on: April 14, 2017, 11:24:45 AM »
l update but now working :S  Management panel does not open.  :2030  not working  :2030/login   not working  :2030/index.php , login.php not working :S please help me.

Offline
*
Re: CentOS6 Upgrade
« Reply #124 on: April 14, 2017, 07:57:29 PM »
try rebooting server and check if cwpsrv works
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: CentOS6 Upgrade
« Reply #125 on: April 14, 2017, 08:41:09 PM »
letting know that the installation went without any problems :)
Apache got it's User error, as mentioned before in this topic.. but just following the instructions and all went well.
Updated MySQL, PHPMyAdmin, CWP panel.. need to check several things, but i've good hope.
My platform is still working as a beast, no worries so far.

Offline
*
Re: CentOS6 Upgrade
« Reply #126 on: April 16, 2017, 11:59:19 AM »
Hi,

I tried to upgrade mysql first (even tho I am on 5.1 (getting new version is good)) and i got this;

Code: [Select]
[root@lucky src]# sh mysql.sh
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 298, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 115, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 229, in getOptionsConfig
    self.conf
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 911, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 300, in _getConf                                                                                        ig
    startupconf = config.readStartupConfig(fn, root)
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 896, in readStartu                                                                                        pConfig
    startupconf.releasever = _getsysver(startupconf.installroot, startupconf.dis                                                                                        troverpkg)
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 1047, in _getsysve                                                                                        r
    hdr = idx.next()
StopIteration
mkdir: cannot create directory `/home/backup': File exists
-- Warning: Skipping the data of table mysql.event. Specify the --events option                                                                                         explicitly.
Stopping mysqld:                                           [  OK  ]
Retrieving http://mirror.webtatic.com/yum/el6/latest.rpm
warning: /var/tmp/rpm-tmp.UUfq6b: Header V4 DSA/SHA1 Signature, key ID cf4c4ff9:                                                                                         NOKEY
error: Failed dependencies:
        redhat-release >= 6 is needed by webtatic-release-6-9.noarch
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 298, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 115, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 229, in getOptionsConfig
    self.conf
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 911, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 300, in _getConf                                                                                        ig
    startupconf = config.readStartupConfig(fn, root)
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 896, in readStartu                                                                                        pConfig
    startupconf.releasever = _getsysver(startupconf.installroot, startupconf.dis                                                                                        troverpkg)
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 1047, in _getsysve                                                                                        r
    hdr = idx.next()
StopIteration
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 298, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 115, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 229, in getOptionsConfig
    self.conf
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 911, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 300, in _getConf                                                                                        ig
    startupconf = config.readStartupConfig(fn, root)
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 896, in readStartu                                                                                        pConfig
    startupconf.releasever = _getsysver(startupconf.installroot, startupconf.dis                                                                                        troverpkg)
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 1047, in _getsysve                                                                                        r
    hdr = idx.next()
StopIteration
/bin/sed: can't read /etc/yum.repos.d/webtatic.repo: No such file or directory
Stopping mysqld:                                           [  OK  ]
Starting mysqld:                                           [  OK  ]
mysql_upgrade: unknown option '--upgrade-system-tables'
MySQL has been upgraded
MySQL backup can be found in /home/backup/

Now whenever I tried to upgrade CWP and Apache this thing keep coming out;
Code: [Select]
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 298, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 115, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 229, in getOptionsConfig
    self.conf
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 911, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 300, in _getConf                                                                                        ig
    startupconf = config.readStartupConfig(fn, root)
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 896, in readStartu                                                                                        pConfig
    startupconf.releasever = _getsysver(startupconf.installroot, startupconf.dis                                                                                        troverpkg)
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 1047, in _getsysve                                                                                        r
    hdr = idx.next()
StopIteration

Thus making my upgrade unsuccessful.
Tried yum clean all but the same thing came out..
Thank you in advance..

Leo

Offline
*
Re: CentOS6 Upgrade
« Reply #127 on: April 17, 2017, 07:46:33 PM »
Hi, roundcube database connection error. get the fix myself.

find and change old password within this file.
Code: [Select]
/usr/local/cwpsrv/var/services/roundcube/config.inc.php
it seems roundcube path changed.
old one was here i think,
Code: [Select]
/usr/local/apache/htdocs/roundcube/config/config.inc.php

best wishes..

« Last Edit: April 17, 2017, 07:55:37 PM by tristar78 »

Offline
*
Re: CentOS6 Upgrade
« Reply #128 on: April 20, 2017, 07:19:52 PM »
Does the new CWP version works fine with apache 2.2 or cwp upgrade must be done with apache upgrade to 2.4?
I would like to make first, CWP upgrade, deal with problems and then, after few weekes, if I decide it is stable, I could upgrade apache.

Offline
*
Re: CentOS6 Upgrade
« Reply #129 on: April 21, 2017, 05:15:52 AM »
Does the new CWP version works fine with apache 2.2 or cwp upgrade must be done with apache upgrade to 2.4?
I would like to make first, CWP upgrade, deal with problems and then, after few weekes, if I decide it is stable, I could upgrade apache.

apache 2.4 is now default and we have it working for a very long time now.
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: CentOS6 Upgrade
« Reply #130 on: April 21, 2017, 12:06:13 PM »
Hi i have an issue with the client side file manager after upgrading to the newer version of cwp on centos 6

CWP version: 0.9.8.222

Checking the apache log gives the error below

No user or group set - set suPHP_UserGroup

URL: http://cwpserver/webftp_simple/
Also tried
URL: http://cwpserver:2030/webftp_simple/

Any assistance would be appreciated.

Thanks


Offline
*
Re: CentOS6 Upgrade
« Reply #131 on: April 22, 2017, 08:57:36 PM »
Hi all after upgrade all the services are running but i receive some warning from mysql]:

Warning: Error while sending QUERY packet. PID=8293 in /usr/local/cwpsrv/htdocs/resources/admin/include/functions.php on line 0

Warning: [obfuscated]() expects exactly 1 parameter, 0 given in /usr/local/cwpsrv/htdocs/resources/admin/include/functions.php on line 0

Warning: [obfuscated]() expects parameter 1 to be mysqli_result, boolean given in /usr/local/cwpsrv/htdocs/resources/admin/include/functions.php on line 0

and also if i want to enter phpmyadmin (roundcube too) receive error 404.

this is the error log:

2017/04/22 21:02:18 [error] 1948#0: *123 FastCGI sent in stderr: "PHP message: PHP Warning:  Error while sending QUERY packet. PID=2256 in /usr/local/cwpsrv/htdocs/resources/admin/include/functions.php on line 0
PHP message: PHP Warning:  [obfuscated]() expects exactly 1 parameter, 0 given in /usr/local/cwpsrv/htdocs/resources/admin/include/functions.php on line 0
PHP message: PHP Warning:  [obfuscated]() expects parameter 1 to be mysqli_result, boolean given in /usr/local/cwpsrv/htdocs/resources/admin/include/functions.php on line 0" while reading upstream, client: 186.133.39.152, server: localhost, request: "GET /admin/index.php?service_restart=mysqld HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "softwareisla.com:2030", referrer: "http://softwareisla.com:2030/admin/index.php?load=update"
2017/04/22 21:09:43 [error] 1948#0: *123 open() "/usr/local/cwpsrv/var/services/pma" failed (2: No such file or directory), client: 186.133.39.152, server: localhost, request: "GET /pma HTTP/1.1", host: "softwareisla.com:2030", referrer: "http://softwareisla.com:2030/admin/index.php?service_restart=mysqld"


please could you helpme to fix this.


im already fix this!! with the restore and re install.

Regards.
« Last Edit: April 22, 2017, 09:46:24 PM by Matias »

Offline
*
Re: CentOS6 Upgrade
« Reply #132 on: April 24, 2017, 01:54:12 PM »
After Upgrade i have Uninstalled Mod security because of problems.
I try the some solutions but not worked for me.
Any good news about this problem? Maybe i have missed solution replies...

Offline
*
Re: CentOS6 Upgrade
« Reply #133 on: April 24, 2017, 04:41:13 PM »
First Post:

Thanks for all you do!

Config:
CWP version: 0.9.8.188
Apache version: Apache/2.4.25
PHP version: 5.6.29
MySQL version: 5.5.54
FTP version: 1.0.36
CentOS release 6.8
Running Apache Only webserver

My Problem after the upgrade:
RAM Usage is maxed out
[root@vps ~]# free -m
             total       used       free     shared    buffers     cached
Mem:     6144       5992        151          5          0       4884
cache:    1107       5036
Swap:            0          0          0

I was running Varnish and Apache before the upgrade and then switched right before the upgrade per the upgrade documentation.

What do you all think?  Server seems to be running fine just want to make sure it is ok before it would only go to 2GBs now it is at 6GBs

Offline
*
Re: CentOS6 Upgrade
« Reply #134 on: April 24, 2017, 07:50:01 PM »
First Post:

Thanks for all you do!

Config:
CWP version: 0.9.8.188
Apache version: Apache/2.4.25
PHP version: 5.6.29
MySQL version: 5.5.54
FTP version: 1.0.36
CentOS release 6.8
Running Apache Only webserver

My Problem after the upgrade:
RAM Usage is maxed out
[root@vps ~]# free -m
             total       used       free     shared    buffers     cached
Mem:     6144       5992        151          5          0       4884
cache:    1107       5036
Swap:            0          0          0

I was running Varnish and Apache before the upgrade and then switched right before the upgrade per the upgrade documentation.

What do you all think?  Server seems to be running fine just want to make sure it is ok before it would only go to 2GBs now it is at 6GBs

Cant edit my post. But now all is back to normal using less than 1GBs