Author Topic: cwp web panel http error 500  (Read 15980 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
cwp web panel http error 500
« on: April 24, 2020, 07:55:52 PM »
Hello, i had ioncube loader version problem and i edited php.ini file in cwp/php71/php.ini and when i skipped the error on my web panel (it was saying restart or contact administrator) now it says error 500, so there was no other info in the google so i created a thread in here to find a solution.

php.ini value is set to 755

restarted everything, rebooted also. nothing happening. centos 6

websites work great, just cwp panel doesnt work

Offline
*
Re: cwp web panel http error 500
« Reply #1 on: April 24, 2020, 09:04:10 PM »
my error_log
Code: [Select]
2020/04/25 00:13:43 [error] 10423#0: *7 FastCGI sent in stderr: "PHP message: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/admin/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0" while reading response header from upstream, client: 37.130.107.213, server: localhost, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "5.135.197.185:2031"
2020/04/25 00:13:44 [error] 10423#0: *7 FastCGI sent in stderr: "PHP message: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/admin/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0" while reading response header from upstream, client: 37.130.107.213, server: localhost, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "5.135.197.185:2031"
2020/04/25 00:13:51 [error] 10423#0: *7 FastCGI sent in stderr: "PHP message: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/admin/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0" while reading response header from upstream, client: 37.130.107.213, server: localhost, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "5.135.197.185:2031"
2020/04/25 00:13:51 [error] 10423#0: *7 FastCGI sent in stderr: "PHP message: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/admin/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0" while reading response header from upstream, client: 37.130.107.213, server: localhost, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "5.135.197.185:2031"
2020/04/25 00:13:54 [error] 10423#0: *7 FastCGI sent in stderr: "PHP message: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/admin/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0" while reading response header from upstream, client: 37.130.107.213, server: localhost, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "5.135.197.185:2031"
2020/04/25 00:15:01 [error] 10422#0: *25 FastCGI sent in stderr: "PHP message: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/admin/admin/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0" while reading response header from upstream, client: 127.0.0.1, server: localhost, request: "GET /admin/index.php?api=y&key=Vpwao5Q3cmTM&action=get_list_of_users HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "127.0.0.1:2031"
2020/04/25 00:17:14 [error] 10422#0: *29 FastCGI sent in stderr: "PHP message: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/admin/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0" while reading response header from upstream, client: 37.130.107.213, server: localhost, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "5.135.197.185:2031"
2020/04/25 00:20:01 [error] 10422#0: *32 FastCGI sent in stderr: "PHP message: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/admin/admin/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0" while reading response header from upstream, client: 127.0.0.1, server: localhost, request: "GET /admin/index.php?api=y&key=Vpwao5Q3cmTM&action=get_list_of_users HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "127.0.0.1:2031"
2020/04/25 00:21:04 [error] 10422#0: *36 FastCGI sent in stderr: "PHP message: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/admin/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0" while reading response header from upstream, client: 37.130.107.213, server: localhost, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "5.135.197.185:2031"
2020/04/25 00:21:05 [error] 10422#0: *36 FastCGI sent in stderr: "PHP message: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/admin/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0" while reading response header from upstream, client: 37.130.107.213, server: localhost, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "5.135.197.185:2031"
2020/04/25 00:21:10 [error] 10422#0: *36 FastCGI sent in stderr: "PHP message: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/admin/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0" while reading response header from upstream, client: 37.130.107.213, server: localhost, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "5.135.197.185:2031"
2020/04/25 00:21:14 [error] 10422#0: *36 FastCGI sent in stderr: "PHP message: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/admin/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0" while reading response header from upstream, client: 37.130.107.213, server: localhost, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "5.135.197.185:2031"
2020/04/25 00:21:24 [error] 10422#0: *36 FastCGI sent in stderr: "PHP message: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/admin/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0" while reading response header from upstream, client: 37.130.107.213, server: localhost, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "5.135.197.185:2031"

Offline
*****
Re: cwp web panel http error 500
« Reply #2 on: April 24, 2020, 10:56:33 PM »
Please update your cwp to the latest version and this will solve this problem.

Offline
*
Re: cwp web panel http error 500
« Reply #3 on: April 24, 2020, 10:58:16 PM »
hello, if the cwp didn't release a new update in 2 days, as i checked its up to date. and also how can i update it ?

Offline
*
Re: cwp web panel http error 500
« Reply #4 on: April 24, 2020, 11:01:55 PM »
hello,
tried to update the cwp and;

Code: [Select]
PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/resources/admin/include/cron                                                                                                             .php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1                                                                                                              or later.
 Please ask the provider of the script to provide a version encoded with the ion                                                                                                             Cube Encoder for PHP 7.1. in Unknown on line 0

Offline
*****
Re: cwp web panel http error 500
« Reply #5 on: April 24, 2020, 11:03:05 PM »
Code: [Select]
sh /scripts/update_cwp

Offline
*
Re: cwp web panel http error 500
« Reply #6 on: April 25, 2020, 12:23:47 AM »
Code: [Select]
sh /scripts/update_cwp

hello again,

it says;

Code: [Select]
PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/resources/admin/include/cron.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0

how can i fix this, i firstly installed cwp with 5.6.40 and updated the version to 7.2.10, and when i installed ioncube loader it was trying to use 7.0, i set the php file to 7.2 ioncube file.

and now this situation happened, can't even reach

Offline
****
Re: cwp web panel http error 500
« Reply #7 on: April 25, 2020, 12:42:40 AM »
please post the output of "php -v"

also ls -al /usr/local/cwp/
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: cwp web panel http error 500
« Reply #8 on: April 25, 2020, 12:47:57 AM »
please post the output of "php -v"

also ls -al /usr/local/cwp/
php -v
Code: [Select]
Cannot load the ionCube PHP Loader - it was already loaded
PHP 7.2.10 (cli) (built: Apr 21 2020 04:40:04) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.3.2, Copyright (c) 2002-2018, by ionCube Ltd.

ls command ;

Code: [Select]
total 16
drwxr-xr-x.  4 root root 4096 Mar 30 13:13 .
drwxr-xr-x. 22 root root 4096 Apr 24 22:50 ..
drw-------.  6 root root 4096 Apr 21 04:47 .conf
lrwxrwxrwx.  1 root root   21 Mar 30 13:13 php -> /usr/local/cwp/php71/
drwxr-xr-x.  9 root root 4096 Apr 24 03:10 php71
lrwxrwxrwx.  1 root root   48 Mar 30 13:13 softaculous -> /usr/local/cwpsrv/var/services/users/softaculous


Offline
****
Re: cwp web panel http error 500
« Reply #9 on: April 25, 2020, 01:09:10 AM »
Try

yum install cwpphp
Google Hangouts:  rcschaff82@gmail.com

Offline
****
Re: cwp web panel http error 500
« Reply #10 on: April 25, 2020, 01:17:02 AM »
http://forum.centos-webpanel.com/index.php?topic=8782.msg30572#msg30572


Check this out. Do a manual update of the files and services to see if it corrects your issues.
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: cwp web panel http error 500
« Reply #11 on: April 25, 2020, 01:48:15 AM »
Try

yum install cwpphp

says already installed and latest version.

trying to do the next solution, thanks for answer but not working.

Offline
*
Re: cwp web panel http error 500
« Reply #12 on: April 25, 2020, 01:53:32 AM »
http://forum.centos-webpanel.com/index.php?topic=8782.msg30572#msg30572


Check this out. Do a manual update of the files and services to see if it corrects your issues.

thank you very much, this link hasn't been indexed by google, thats why i couldn'T find it I think.

Loved you and thank you very much also the solution giver thankss a lottt!!!!

this worked for me.