Author Topic: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:4  (Read 10259 times)

0 Members and 1 Guest are viewing this topic.

Hi there,

Today one of my CWP-server's apache stopped working totally (no response on port 80 or 443) and when I tried to restart it, it just gives:

"(98)Address already in use: AH00072: make_sock: could not bind to address [::]:443" -error.

I have tried to rebuild virtual hosts several times with no help on this issue.

On select web servers page I have "Apache only" selected.

"netstat -tpan|grep 443" gives no results so according to it, nothing is listening at port 443

On /usr/local/apache/conf.d/ grep 443 gives following results:

[root@s1 conf.d]# grep 443 * -R
ssl.conf:Listen 443

on /usr/local/apache/conf/ it gives following:

extra/httpd-ssl.conf:Listen 443
extra/httpd-ssl.conf:<VirtualHost _default_:443>
original/extra/httpd-ssl.conf:Listen 443
original/extra/httpd-ssl.conf:<VirtualHost _default_:443>

Should I remove those additional Listen 443 directives from some of the files?

Or any other ideas how I could get apache back working?


Comment or remove the line in your /usr/local/apache/conf.d/ssl.conf :

Listen 443

Then add it below the line "Listen 80" in your /usr/local/apache/conf/httpd.conf.

Banged my head against the wall for hours and tried everything and that's the only thing that worked for me

Hope this helps.
« Last Edit: July 19, 2017, 03:05:19 PM by vccnet »

if you don't use ssl (you have no vhosts in your /usr/local/apache/conf.d/vhosts-ssl.conf file then you can simply remove/delete ssl.conf file and restart apache.

don't worry about this file, when you install ssl for any domain it will be created automatically.
VPS & Dedicated server provider with included FREE Managed support for CWP.

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.