Author Topic: rDNS/PTR Failed for hostname  (Read 19370 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
rDNS/PTR Failed for hostname
« on: July 28, 2017, 01:50:09 PM »
I have an issue with rDNS/PTR in CWP.
When I go to Server Settings -> Change Hostname, or Email -> MailServer Manager, I receive the follow message:

Your Hostname is: srv1.mydomain.com and it resolves to IP: mydomain.com. 10.20.30.40 [Check Black List]
rDNS/PTR = FAILED, check with your hosting provider! FAILED [Check SenderBase]


(domain name and IP changed)

When I check my DNS records for mydomain.com (DNS Functions -> List DNS Zones -> [mydomain.com.db] Check Records), I get this result:

rDNS/PTR record check: SUCCESS
rDNS/PTR = srv1.mydomain.com
rDNS A record = 10.20.30.40 [Check SenderBase] [Check RBL]



The content of mydomain.com.db (domain name and ip changed):

Code: [Select]
; Panel %version%
; Zone file for mydomain.com
$TTL 14400
mydomain.com.      86400        IN      SOA     ns1.mydomain.com. user.email.com. (
         2013071601      ; serial, todays date+todays
                86400           ; refresh, seconds
          7200            ; retry, seconds
            3600000         ; expire, seconds
           86400 )         ; minimum, seconds

mydomain.com. 86400 IN NS ns1.mydomain.com.
mydomain.com. 86400 IN NS ns2.mydomain.com.

mydomain.com. IN A 10.20.30.40
srv1.mydomain.com. IN A 10.20.30.40

localhost.mydomain.com. IN A 127.0.0.1

mydomain.com. IN MX 0 srv1.mydomain.com.

www IN CNAME mydomain.com.
ftp IN CNAME mydomain.com.

; Add additional settings below this line
default._domainkey 14400 IN TXT "v=DKIM1; k=rsa; p=MIGf..."

ns1     14400   IN      A       10.20.30.40
ns2     14400   IN      A       20.30.40.50

mydomain.com. IN TXT "v=spf1 mx a"
_dmarc.mydomain.com. IN TXT "v=DMARC1; p=none; rua=mailto:webmaster@mydomain.com"


Finally, cat /etc/hostname results in:
srv1.mydomain.com

There are something wrong in my dns configuration?
« Last Edit: July 28, 2017, 02:07:32 PM by Jefferson Felix »

Offline
*
Re: rDNS/PTR Failed for hostname
« Reply #1 on: July 28, 2017, 05:16:11 PM »
Problem solved.
My ns2 was out.
I restarted ns2, reloaded dns and it's all OK.

Offline
*
Re: rDNS/PTR Failed for hostname
« Reply #2 on: January 06, 2020, 01:24:46 AM »
I also have the same error as you, can you show me how to FIX.
Thanking you.

Offline
**
Re: rDNS/PTR Failed for hostname
« Reply #3 on: April 04, 2020, 09:47:07 AM »
Same issue. More details on how you solved this?

Offline
*
Re: rDNS/PTR Failed for hostname
« Reply #4 on: March 03, 2021, 04:06:14 PM »
I would like same info please, can admin fix this issue with support? thank you

Offline
***
Re: rDNS/PTR Failed for hostname
« Reply #5 on: March 03, 2021, 06:11:58 PM »
rdns/ptr records are not handled by CWP.  rdns = REVERSE DNS.  Thus whoever owns your IP Address needs to set your PTR record to resolve the IP address to your domain name.

if you do "dig -x {IP}", you should see what your ptr is currently resolved to
you can also "dig soa {IP}" to find out who to contact to set your PTR.

Best option if it doesn't resolve to your hostname, is to contact your Hosting provider.
Google Hangouts:  rcschaff82@gmail.com

Online
*
Re: rDNS/PTR Failed for hostname
« Reply #6 on: March 13, 2021, 03:46:47 PM »
The best way as already said is to tell your ISP to change your rDNS to something like mail.yourdomain.com

BUT:

As some ISP's aren't very kind or telling you there is no way to change the rDNS Pointer they set for you there is another way to solve this.

The rDNS is only needed for Mails, you can also go into your main.cf and change your hostname only in that config to fit your rDNS

open: /etc/postfix/main.cf

Find:
myhostname = srv1.yourdomain.com

and just change it to your fitting rDNS. Eg mail.yourdomain.com or simply yourdomain.com (you need to find out whats your rDNS)

Save the config and restart postfix.

Thats all you need to do.

Offline
*****
Re: rDNS/PTR Failed for hostname
« Reply #7 on: March 14, 2021, 02:10:04 PM »
it is recommended to user same server hostname and rdns.