Author Topic: Auto SSL /Let's Encrypt  (Read 24442 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Auto SSL /Let's Encrypt
« on: October 27, 2019, 04:21:46 PM »
Hi.

Im new to CWP, and hope for som guidens :-)

I want to setup the auto SSL / Let's Encrypt.
Is there any good tutorials ?

Thanks :-)

Offline
*
Re: Auto SSL /Let's Encrypt
« Reply #1 on: October 27, 2019, 10:15:46 PM »
Ehm... it's build in :-) So no extra setup needed.

How to apply Let's Encrypt.. To avoid mistakes, On the left side, go to user accounts click on the triangle and select New Account Fill out the form presented to you with the relevant information.
At the bottom, don't select the AutoSSL yet! Click on the blue Create button and CWP goes to work.

Check if everything is to your liking and that you can access the just created domain. If that is the case from the left menu now choose Webserver Settings Almost at the end of the list you will see SSL Certificates time to click on that one.

You will presented with a tabbed menu, choose the tab AutoSSL [FREE] from the dropdown menu pick the User you just created and the domain, if it matches the Install SSL button changes to a different shade of blue and clickable. Click on it and the SSL certificates will install without any problems.

Doing it this way avoids some potential problems that if you create a user and domain the DNS or NGINX / Apache / Vhost did not catch up yet. What will give an error since the SSL check can't find the domain.