Author Topic: RewriteEngine doesn't work for "profile"  (Read 6951 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
RewriteEngine doesn't work for "profile"
« on: January 12, 2015, 11:27:35 PM »
In my website I use RewriteEngine for seo optimization, but I found that if you try use "profile" in rewriting link it doesn't work properly.

Here's an example:

RewriteRule ^profile/([0-9]+)/.+/?$ profile.php?id=$1 [L]

RewriteRule ^profiles/([0-9]+)/.+/?$ profile.php?id=$1 [L]

Link1: http://www.site.com/profile/1/username

Link2: http://www.site.com/profiles/1/username

Both links must loaded to http://www.site.com/profile.php?id=1

But actually only the link2 works properly.

Link1 returns 404 error or some custom pages.

This is a bug caused by CWP because other panels not have this problem and both links works properly.

Offline
*
Re: RewriteEngine doesn't work for "profile"
« Reply #1 on: January 19, 2015, 02:40:43 AM »
have you checked the logs and is this maybe related with the mod_security?
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services