Author Topic: edit install script to only install 5.5/5.6 and mariadb  (Read 8462 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
edit install script to only install 5.5/5.6 and mariadb
« on: January 18, 2015, 01:47:48 PM »
Hi,
is there a way to completely AVOID installing PHP 5.4 and have 5.5/5.6 instead in the default install ?

I notice in the install script:
Code: [Select]
Line 155: wget -q http://dl1.centos-webpanel.com/files/c_scripts/php-5.4-cwp.sh
Line 157: wget -q http://dl1.centos-webpanel.com/files/c_scripts/php-5.4.sh

Do you have a 5.5/5.6 package that can be called in by the script?

Same for the Mariadb
Code: [Select]
Line 91: yum -y install make rsync mysql-server at mysql-devel bzip2-devel zip git pure-ftpd unzip cronie
Line 91: yum -y install make rsync mysql-server at mysql-devel bzip2-devel zip git pure-ftpd unzip cronie
Can I replace it with Mariadb instead ?

pls give me an insight. Good Work on the Panel though! I like the gui alot. Just giving it a good try for custom packages, as seasoned admins would love to have some custom pkg for performance.

Offline
*
Re: edit install script to only install 5.5/5.6 and mariadb
« Reply #1 on: January 19, 2015, 03:38:26 AM »
after installation of CWP is done then you can make the custom modifications according to your needs
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: edit install script to only install 5.5/5.6 and mariadb
« Reply #2 on: January 19, 2015, 09:13:29 PM »
so you mean I remove MySql and install mariadb with Yum ? and remove PHP 5.4 & 5.5 and install 5.6 alone ? will the CWP be able to detect it properly ? and configure the domains correctly ?

Offline
*
Re: edit install script to only install 5.5/5.6 and mariadb
« Reply #3 on: January 30, 2015, 09:47:22 PM »
1- Yes, just add repository of MariaDB and install via yum and all should be fine.
2- For php, via your admin panel, you have PHP Version Switcher where you can up your server UP to 5.5.11

I hope I answered your questions

Cheers
so you mean I remove MySql and install mariadb with Yum ? and remove PHP 5.4 & 5.5 and install 5.6 alone ? will the CWP be able to detect it properly ? and configure the domains correctly ?

Offline
*
Re: edit install script to only install 5.5/5.6 and mariadb
« Reply #4 on: February 04, 2015, 01:30:44 AM »
you don't need to remove mysql, you only need to upgrade it, and yes you can use mariaDB repo.
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services