Author Topic: ssl expire  (Read 25962 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
Re: ssl expire
« Reply #15 on: October 10, 2018, 11:25:00 PM »

But you can add this to each domain in vhost file.

<IfModule mod_rewrite.c>
   RewriteEngine on
   RewriteCond %{HTTPS} off
   RewriteRule ^(.*)$ https://yourdomain.com$1 [R=301,L]
   </IfModule>

Is it possible and how to add this to the vhost template instead of each domain?

Offline
*
Re: ssl expire
« Reply #16 on: December 14, 2018, 05:23:28 AM »
I found that Google wasn't updating from my DNS propagation https://dnschecker.org.   Once Google displayed the A record for my domain I did the following:
1. logged in to the CWP admin http://ipaddress:2030 as root
2. Created a new user with the domain I wanted to use with AutoSSL
3. Went to DNS Functions ->List DNS Zones and pressed   Check All Zones and makde sure they all had an ip address assigned.
4. User Acoounts -> Fix Permissions and selected the user I created and fixed the permissions
5. logged out CWP admin and Logged into CWP user panel with the newly created user
6. Domains -> AutoSSL selected the domain and pressed install
7. confirmed the Test1, Test2, Test3 all passed. 
That was it!!
 So the key for me was whether you are using the built in Bind server in CWP or in my case specified 2 external DNS servers, they all have to resolve on Google DNS before this works

Offline
*
Re: ssl expire
« Reply #17 on: November 03, 2022, 05:12:43 PM »
I have just figured my problem thanks to this post.
http://forum.centos-webpanel.com/ssl/dns-of-your-domain-doesn't-point-to-this-server-or-you-have-htaccess-5490/msg19395/#msg19395

I did have a redirect in my nginx_proxy_vhost to force http to https with this.
Code: [Select]
return 301 https://$host$request_uri;
I have to removed that off and then after certs installed, I put it back. I wish there's a better solution for the force redirect from http to https. If anyone knows of a better solution then please let me know.

Hello dear, can you please help me to find the file location. somehow i edited this file and now auto ssl isnt working.