Author Topic: pure-ftpd won't start after yum update October2018  (Read 5749 times)

0 Members and 1 Guest are viewing this topic.

pure-ftpd won't start after yum update October2018
« on: October 30, 2018, 02:04:44 PM »
Hi Guys,

My command line hung for ages while doing a yum update for pure-ftp. After about 20 minutes I aborted it and found that pure-ftp would not start. Here's the output of the history info for that yum update job:

Code: [Select]

[root@server ~]# yum history info 68
Loaded plugins: fastestmirror
Transaction ID : 68
Begin time     : Tue Oct 30 12:26:44 2018
Begin rpmdb    : 468:4c1d59a12ba9f4fcabf30dad3a151a6a89b9080f
User           : root <root>
Return-Code    : ** Aborted **
Command Line   : update
Transaction performed with:
    Installed     rpm-4.8.0-59.el6.x86_64                          @base
    Installed     yum-3.2.29-81.el6.centos.0.1.noarch              @updates
    Installed     yum-plugin-fastestmirror-1.1.30-42.el6_10.noarch @updates
Packages Altered:
 ** Updated pure-ftpd-1.0.36-1.el6.rf.x86_64 @rpmforge
 ** Update            1.0.46-1.x86_64        installed
 ** Updated tzdata-2018e-3.el6.noarch        @updates
 ** Update         2018f-1.el6.noarch        @updates
Scriptlet output:
   1 warning: /etc/pure-ftpd/pure-ftpd.conf saved as /etc/pure-ftpd/pure-ftpd.conf.rpmsave
   2 chkconfig version - Copyright (C) 1997-2000 Red Hat, Inc.
   3 This may be freely redistributed under the terms of the GNU Public License.
   5 usage:   chkconfig [--list] [--type <type>] [name]
   6          chkconfig --add <name>
   7          chkconfig --del <name>
   8          chkconfig --override <name>
   9          chkconfig [--level <levels>] [--type <type>] <name> <on|off|reset|resetpriorities>
  10 Stopping pure-ftpd: [  OK  ]
  11 Starting pure-ftpd: /usr/bin/dirname: extra operand `.pid'
  12 Try `/usr/bin/dirname --help' for more information.
  13 [  OK  ]
history info

As you can see a warning message did show up that said "warning: /etc/pure-ftpd/pure-ftpd.conf saved as /etc/pure-ftpd/pure-ftpd.conf.rpmsave." Now, pure-ftpd won't start, plus I've tried to downgrade and it won't. I'm stuck with this error.

I get this message every time I try to restart pure-ftpd now:

"Starting pure-ftpd: /usr/bin/dirname: extra operand `.pid'
Try `/usr/bin/dirname --help' for more information.

Any ideas?

Thanks, Mark
« Last Edit: October 30, 2018, 02:06:34 PM by cockers »

Re: pure-ftpd won't start after yum update October2018
« Reply #1 on: November 02, 2018, 04:19:07 PM »

Same problem here. When I tried to reboot vps after the problem the whole server crashedsom I had to restore backup. I thought this was a one time episode so I ran Yum update on another server today and the same problem acured.

Anoyone have any ideas?

Re: pure-ftpd won't start after yum update October2018
« Reply #2 on: December 02, 2018, 08:54:15 AM »
A reboot fixed this.