Author Topic: Wordpress - High-Performance instructions  (Read 26923 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Re: Wordpress - High-Performance instructions
« Reply #15 on: April 01, 2019, 03:17:54 PM »
hi, am here for a question about varnis and wordpress.. is Varnish default vhost template "wordpress" suggested for any kind of wordpress site?
thx

Offline
**
Re: Wordpress - High-Performance instructions
« Reply #16 on: April 01, 2019, 07:39:33 PM »
Yes. Varnish will not handle requests with cookies and WordPress uses cookies so they have to be stripped. Thats done via the config file so pick the wordpress template.

Offline
*
Re: Wordpress - High-Performance instructions
« Reply #17 on: April 17, 2019, 11:39:15 AM »
after install Nginx & Varnish & Apache on my server and made custom configuration for domains all my wordpress site links changed to https!
It was on http, I didn't install ssl on this domain and didn't change anything on .htaccess or wp-config.php
when I change webserver to simple Apache problem solves.

what's wrong?

Offline
*
Re: Wordpress - High-Performance instructions
« Reply #18 on: May 03, 2019, 05:56:30 PM »
I have two image resources that should never be cached. Nice with Apache only but how to apply the caching rules with this setting?
When I switch to this server configuration Varnish and Nginx need a special configuration to bypass caching rules for these resources. What rules and where must they be added in the vHost-Configs for Varnish and Nginx for the resources with URLs https://example.com/webcam/new.jpg and https://example.com/resize/webcam-small.jpg?

Offline
**
Re: Wordpress - High-Performance instructions
« Reply #19 on: November 07, 2019, 03:32:21 AM »
Hello!
First of all thanks for the update and for the great job.

But the following is missing:

  • To be able to activate the Brotli extension for file compression which is much better GZIP. https://centos.pkgs.org/7/remi-x86_64/php72-php-brotli-0.6.1-1.el7.remi.x86_64.rpm.html
  • To be able to edit from each account (List Accounts) or since the same configuration of Manager Web Server the Vhosts, PHP.ini, Nginx,Varnish, Extensions, DNS and this all centralized in a same place for an account/domain/webserver.
  • Also when accessing by SSH to a domain where the PHP version is 7.2 I tried to run PHP Composer, but I had problems updating packages because the global version of CLI was 5.6, is it possible to configure it for the same version of PHP?

PROBLEM SOLVED

Hi, i discovered a great website https://www.mysterydata.com/ with a great administrator where you can find many guides for CWP and more, also by registering for free on the forum i found the solution to this problem thanks to the courtesy and extreme availability of the administrator.

SOLUTION:

https://forum.mysterydata.com/topic/2/cwp-brotli-not-work-and-nginx-not-start-after-upgrade-of-cwp-pro-from-v0-9-8-906-to-cwp-pro-v0-9-8-907-even-with-the-last-update-to-cwp-pro-v0-9-8-913/7

Good day and good work to all !


Stay hungry, stay foolish.

Offline
*
Updateing from Centos 6 to 8 with CWP7PRO
« Reply #20 on: March 30, 2021, 08:26:40 AM »
So I how RogersRaiders.com and the 800k people who came through last month started me looking through the next few years.
Need to get better at mobile look yada,  Need to handle App's with same data. Yada. Need to start thinking about the next generation of graphics. Screeching halt on Centos 6  thus all the new stuff.

I loved my centos 6 setup I deployed a G6 server 10 years ago never replaced a ram stick, hard drive or had a hiccup and we used 40 gig SSD's LONG before there were server ready SSD's  Now we are new cutting edge for severs NVME drives  DDR 4 ram vs 2 plus all the software updates over a decade.
So WordPress for gaming community just kinda works.  I say kinda cause everything is an out of place piece and frankly the guys who build plugin's don't seem to use them in large traffic places So stuff is always not quiet a good fit.

Before i had apache not 3 diffferent versions of apache so add to my confusion where i have not had to worry about anything for 10 years cause it worked.

But in Wordpress now uploading JPEG's and the WP platform needs to convert them to latest Web Friendly formats.  Centos 6 couldn't do this because you couldn't use the GD library properly without downgrading php back to 5.6 from the 7.4 I was already using.

Quote
Requests to images are processed by your server bypassing Apache. When loading images, rules from the .htaccess file are not executed. Occasionally, this only applies to known file extensions: .jpg, .png, etc. and when e.g. .png2 extension is loaded, then the redirections from the .htaccess file work, because the server does not understand this format and does not treat it as image files. Check the redirects for .png file (for which the redirection does not work) and for .png2 file (for which the redirection works correctly).

Change the server settings to stop ignoring the rules from the .htaccess file. Please contact your server administrator.

Also try changing option "Image loading mode" to a different one. Issues about rewrites can often be resolved by setting this option to "Pass Thru". You can do this in plugin settings below. After changing settings, remember to flush cache if you use caching plugin or caching via hosting.

---

Error codes: bypassing_apache

Thats the message i am getting. I have been going through video's and tutorials but to be fair while I have learned a lot.  There is a BUNCH of assumption that new users KNOW where things are or What they are.  My brain is now dated. 

So server setup, WP setup, and Apache/php setup and oh for the freaking love of god has no one noticed we need global permission to email our own users anymore.
I am paying for the monthly support but frankly I shouldn't have to get to a stopping point and UNDERSTAND whats broke to explain it.  If I understood what was broke I would fix it.

For instance i know I can't connect to port 465 the WP software says i can't. But i know the port is open in CSF and the firewalld hardware is turned off.  So what crazy place did someone save the world from a spammer that just happens to put me out of business  until i gain new knowledge?

I wanted the teamspeak 3 server plugin so i can sell teamspeak servers but find out not supported because teamspeak may charge me a late fee for not paying my bill on time?  What does that have to do with the module being there and working me paying my bills is my problem not CWP's
Its apparent there is some make work foreplay in the cwp maybe someone can send me to someone who will help me get my company back working so tha ti can actually pay someone to do the upgrades.