Author Topic: How to increase post_max_size in CWP?  (Read 4767 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
How to increase post_max_size in CWP?
« on: January 24, 2019, 03:29:51 AM »
Hi all,

We've edited php.ini in both CWP + User panel as well user.ini under public_thml folder with the following configs

Code: [Select]
upload_max_filesize = 64M
post_max_size = 64M
memory_limit = 512M
max_execution_time = 120
max_input_vars = 10000
max_input_time = 400

Our Wordpress or SuiteCRM keep on informing we only have

Code: [Select]
'max_execution_time' parameter on your hosting/server is 30 seconds, 120 seconds recommended
'post_max_size' parameter on your hosting/server is 8 Mb, 40Mb recommended
'upload_max_filesize' parameter on your hosting/server is 2 Mb, 40Mb recommended

Is there anywhere else that we could look into?

Thanks for any advice given

Offline
**
Re: How to increase post_max_size in CWP?
« Reply #1 on: January 24, 2019, 06:16:13 PM »
Move the .user.ini file into the wp-admin folder or edit the yourdomain.conf file here:

Code: [Select]
/usr/local/apache/conf.d/vhosts
Remove the trailing slash from localhost line.

Code: [Select]
<IfModule proxy_fcgi_module>
<FilesMatch \.php$>
SetHandler "proxy:unix:/opt/alt/php-fpm73/usr/var/sockets/gtmanage.sock|fcgi://localhost"
</FilesMatch>
</IfModule>

The trailing slash is in the template file so every time you rebuild vhost files it will be added again. I have reported the bug a month ago and it was supposed to be fixed. You can create a copy and edit the templates here:
Code: [Select]
/usr/local/cwpsrv/htdocs/resources/conf/web_servers/vhosts/httpd/php-fpm
See here for more info.
http://wiki.centos-webpanel.com/webservers-vhost-templates

 

Offline
*
Re: How to increase post_max_size in CWP?
« Reply #2 on: January 25, 2019, 02:19:41 PM »
Move the .user.ini file into the wp-admin folder or edit the yourdomain.conf file here:

Hi GT, thanks for lending a hand.

the first option doesn't seem to work, I have put the user.ini to both public_html + wp-admin folder still no luck...


Offline
**
Re: How to increase post_max_size in CWP?
« Reply #3 on: January 25, 2019, 02:38:23 PM »
Just to be clear it's .user.ini

Offline
*
Re: How to increase post_max_size in CWP?
« Reply #4 on: January 25, 2019, 02:47:46 PM »

Remove the trailing slash from localhost line.

Code: [Select]
<IfModule proxy_fcgi_module>
<FilesMatch \.php$>
SetHandler "proxy:unix:/opt/alt/php-fpm73/usr/var/sockets/gtmanage.sock|fcgi://localhost"
</FilesMatch>
</IfModule>


I figured the team has already fixed the bug

there isn't any trailing slash at the end of localhost line.



any more places we could look into to change upload_max_filesize value?

Offline
*
Re: How to increase post_max_size in CWP?
« Reply #5 on: January 25, 2019, 02:52:11 PM »
Just to be clear it's .user.ini

lol this fixed this, I missed the dot!

thanks for pointing it out!  ::)