Author Topic: CSF and CWP  (Read 7699 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
CSF and CWP
« on: February 18, 2019, 08:46:04 AM »
CWP seems to think that CSF is disable but when i run

[root@vmi240766 ~]# csf -e
csf and lfd are not disabled!

So it seems to be some sort of bug here? What to do?

https://imgur.com/a/LFDPhi1

Offline
*****
Re: CSF and CWP
« Reply #1 on: February 18, 2019, 11:32:58 AM »
Hello,

Please run the following command to check if csf can run on your system
perl /usr/local/csf/bin/csftest.pl

Offline
*
Re: CSF and CWP
« Reply #2 on: February 18, 2019, 11:41:51 AM »
[root@vmi240766 ~]# perl /usr/local/csf/bin/csftest.pl
Testing ip_tables/iptable_filter...OK
Testing ipt_LOG...OK
Testing ipt_multiport/xt_multiport...OK
Testing ipt_REJECT...OK
Testing ipt_state/xt_state...OK
Testing ipt_limit/xt_limit...OK
Testing ipt_recent...OK
Testing xt_connlimit...OK
Testing ipt_owner/xt_owner...OK
Testing iptable_nat/ipt_REDIRECT...OK
Testing iptable_nat/ipt_DNAT...OK

RESULT: csf should function on this server

Offline
*****
Re: CSF and CWP
« Reply #3 on: February 18, 2019, 12:45:58 PM »
Please reinstall
Before doing that please backup csf.conf file with cp /etc/csf/csf.conf /etc/csf/csf.conf.bak

cd /usr/src
rm -fv csf.tgz
wget https://download.configserver.com/csf.tgz
tar -xzf csf.tgz
cd csf
sh install.sh

After please restore csf.conf

Offline
*
Re: CSF and CWP
« Reply #4 on: February 18, 2019, 02:27:44 PM »
Same thing. It still say the same information.

Offline
***
Re: CSF and CWP
« Reply #5 on: February 20, 2019, 03:06:43 AM »
Have you ever tried to disable it before?

The commands sequence:
Code: [Select]
# csf -x; csf -e

Regards,
Netino

Offline
*
Re: CSF and CWP
« Reply #6 on: February 20, 2019, 07:54:09 AM »
Have you ever tried to disable it before?

The commands sequence:
Code: [Select]
# csf -x; csf -e

Regards,
Netino

What do you mean?

Offline
***
Re: CSF and CWP
« Reply #7 on: February 23, 2019, 03:19:10 AM »
Quote
What do you mean?

Instead to run just:
Code: [Select]
# csf -e

Code: [Select]
# csf -x; csf -e

Offline
*
Re: CSF and CWP
« Reply #8 on: March 30, 2022, 01:17:08 AM »
Hi. i am facing the same isue.
Did you find any solution?
Thank you.
I now removed /etc/csf and reinstall csg. Let's see if now is going to work.
usually i can see it enabled, but after 15 minutes it shows disabled.

I noticed that this error appear because LFD gets disabled.
Fortunately, CSF stays enabled, but LFD is also very important.

Offline
*
Re: CSF and CWP
« Reply #9 on: March 30, 2022, 01:35:52 AM »
It's been 25 minutes and no problems yet.
So it seems that removing /etc/csf and use the above "reinstallation guide", will fix the problem.
it may be the csf.conf we messed up.
So i will now add back my:
csf.ignore
csf.allow
csf.deny
csf.dyndns

Then restart and wait again. if everything goes well, i will try to modify csf.conf back to my previews settings so i can see which setting is not good.

Offline
*
Re: CSF and CWP
« Reply #10 on: March 30, 2022, 02:13:03 AM »
It has been more than 40 minutes and still works.
So definetly removing /etc/csf and reinstalling, will fix the isue.
Couldn't figure out which setting i messed in csf.conf. So you better do all over again, but be more prudent.

Offline
*
Re: CSF and CWP
« Reply #11 on: April 24, 2022, 02:23:42 PM »
CWP seems to think that CSF is disable but when i run

[root@vmi240766 ~]# csf -e
csf and lfd are not disabled!

So it seems to be some sort of bug here? What to do?

https://imgur.com/a/LFDPhi1

This error is due to the configuration LF_IPSET=1 and CC_DENY="country code"
fix is running yum install ipset command and reboot => OK