Author Topic: ImageMagick packages not updating  (Read 220 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
ImageMagick packages not updating
« on: June 14, 2022, 05:30:35 AM »
We have tried updating through commandline and also from the control web panel's package updating window.
in both the cases it is not updating.
Please find me a way for this.

ERRORS :
Error:
 Problem 1: package ImageMagick-perl-6.9.12.50-1.el8.x86_64 requires perl(:MODULE_COMPAT_5.32.1), but none of the providers can be installed
  - package ImageMagick-perl-6.9.12.50-1.el8.x86_64 requires libperl.so.5.32()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package ImageMagick-perl-6.9.12.48-2.el8.x86_64
  - package perl-libs-4:5.32.1-471.module_el8.6.0+1070+343f8e3c.x86_64 is filtered out by modular filtering
 Problem 2: package ImageMagick-perl-6.9.12.48-2.el8.x86_64 requires ImageMagick-libs(x86-64) = 6.9.12.48-2.el8, but none of the providers can be installed
  - problem with installed package ImageMagick-perl-6.9.12.48-2.el8.x86_64
  - cannot install both ImageMagick-libs-6.9.12.50-1.el8.x86_64 and ImageMagick-libs-6.9.12.48-2.el8.x86_64
  - package ImageMagick-perl-6.9.12.50-1.el8.x86_64 requires perl(:MODULE_COMPAT_5.32.1), but none of the providers can be installed
  - package ImageMagick-perl-6.9.12.50-1.el8.x86_64 requires libperl.so.5.32()(64bit), but none of the providers can be installed
  - cannot install the best update candidate for package ImageMagick-libs-6.9.12.48-2.el8.x86_64
  - package perl-libs-4:5.32.1-471.module_el8.6.0+1070+343f8e3c.x86_64 is filtered out by modular filtering
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)


Error:
 Problem: conflicting requests
  - nothing provides ImageMagick-libs(x86-64) = 6.9.12-52 needed by ImageMagick-6.9.12-52.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)