Author Topic: website didn't get correct location  (Read 9448 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
website didn't get correct location
« on: April 06, 2015, 08:02:23 AM »
Hi,

I follow guide to setup CWP , Varnish, create user account, set Fix permission..... restart Apache many times.

I upload my website by FTP account to public_html , but i still get http test page.

so, i rename index.html file to index_1.html, and i get the content below on my website:

Index of /

index_1.html
phpMyAdmin/
roundcube/
webftp_simple/

Website is not get correct location in public_html , BUT, now i can get any images on link  :

www.mydomain.com:82/images/picture.jpg ==> it's show the picture
www.mydomain.com/images/picture.jpg ==> it's show message "Not Found . The requested URL /images/picture.jpg was not found on this server.


I check Apache, Varnish : it still works

This is the information in Edit Apache vHosts :

# vhost_start mydomain.com
<VirtualHost 123.123.123.123:82>
ServerName mydomain.com
ServerAlias www.mydomain.com
ServerAdmin myemail@gmail.com
DocumentRoot "/home/cwpvps/public_html"
ScriptAlias /cgi-bin/ "/home/cwpvps/public_html/cgi-bin/
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/cwpvps/mydomain.com/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup cwpvps cwpvps
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup cwpvps cwpvps
        suPHP_ConfigPath /home/cwpvps
</IfModule>

<Directory "/home/cwpvps/public_html">
        AllowOverride All
</Directory>

</VirtualHost>
# vhost_end mydomain.com


Please help me to fix this issue.

Many thanks
« Last Edit: April 06, 2015, 11:43:16 AM by quachat »

Offline
*
Re: website didn't get correct location
« Reply #1 on: April 06, 2015, 11:38:47 AM »
Anyone can help me, please.

Re: website didn't get correct location
« Reply #2 on: April 06, 2015, 01:37:49 PM »
if you have varnish installed you can goto  CWP Settings > Edit Settings and change IP to 127.0.0.1 and then restart apache (service httpd restart).
« Last Edit: April 06, 2015, 03:15:26 PM by BullTen »