Author Topic: dovecot.log Fatal: Invalid user settings. Refer to server log for more info  (Read 6953 times)

0 Members and 1 Guest are viewing this topic.

Hi guys, on relative new CWP config on Centos, I created an email address and I tried to configure Outlook to connect.
When I failed to connect, I tried to login on Roundcube who failed as well.

So I look in the dovecot log and found that error:

lda(email@domain.tld): Error: User initialization failed: Initializing mail storage from mail_location setting failed: mkdir(/var/vmail/domain.tld/email) failed: Permission denied (euid=101(vmail) egid=12(mail) missing +w perm: /var/vmail, UNIX perms appear ok (ACL/MAC wrong?))

lda: Fatal: Invalid user settings. Refer to server log for more information.

Any ideas what to do? I hate the mail server config :(((

Seems that the issue it's SElinux related.

If I put the SElinux on permissive mode, all work right.
But to disable the SElinux it's not recommended, so this is a bug in config.

Maybe some experienced admin can help us with a workaround for this situation.
Thank you

The command "semanage permissive -a dovecot_t" it puts dovecot into a permissive mode and we can connect to mail server.
But that is not the right way to resolve the problem, it's just a temporary solution.

Any good solution guys?

I am not sure you need SELINUX.
I know that at least one competing control panel Ispconfigv3 had it disabled in tutorials written as recently as 2 years ago (I'm assuming that is still the same because ispconfig v3 has been out for at least that long.
I'm not even sure it's enabled in virtualmin either?

Hi Adam, you are right in principle, even for cPanel & WHM to run on properly, SELinux must remain disabled.
SELinux it's useful to enforce the security of the server, and I was happy when I saw that CWP PRO has support for it.

From what I read around the forums, always errors had appeared between SELinux and Dovecot or Postfix.
Official SELinux support says that it's designed to work well with Dovecot but in custom configurations as on control panels there are always big chances to appear some errors.

Since it was included directly in the CWP PRO, it meant that it was also compatible rules in place to run without hassle.
But seems that after last updates, and SELinux updates too some issues appeared.

Unfortunately, I do not have the necessary knowledge to develop this set of rules, which is why I made this topic, maybe several heads will find a viable solution.