Author Topic: LiteSpeed web server gives PHP extension errors  (Read 4068 times)

0 Members and 1 Guest are viewing this topic.

LiteSpeed web server gives PHP extension errors
« on: December 22, 2019, 02:26:31 PM »
I've tested all web server options on CWP7Pro on CentOS7 and all worked ok except for the LiteSpeed Enterprise option which gave some PHP extension errors on two website platforms. WordPress says "Your PHP installation appears to be missing the MySQL extension which is required by WordPress" and Microweber says "Error: OpenSSL PHP extension is required to run Microweber". The PHP 7.3.11 and MySql 10.1.43-MariaDB configuration worked fine for all other web servers.

PHP-FPM is installed but not active, does PHP-FPM need to be uninstalled?

Also after the LiteSpeed build I noted the following error: "Notice: Undefined variable: row in /usr/local/cwpsrv/htdocs/resources/admin/modules/WebServers_manage.php on line 0"
« Last Edit: December 22, 2019, 02:34:44 PM by nickw »

Re: LiteSpeed web server gives PHP extension errors
« Reply #1 on: December 22, 2019, 05:05:52 PM »
I've enabled LiteSpeed PHPvia PHP Settings --> PHP Version Switcher as described at

mysqli, mysqlnd and openssl extensions are both listed in PHP Short info.

The configuration command shown at the bottom of Php info is:
Configure Command =>  './configure'  '--with-config-file-path=/usr/local/php' '--with-config-file-scan-dir=/usr/local/php/php.d' '--with-zlib=/usr' '--enable-mbstring' '--enable-zip' '--enable-bcmath' '--enable-pcntl' '--enable-ftp' '--enable-exif' '--enable-calendar' '--enable-sysvmsg' '--enable-sysvsem' '--enable-sysvshm' '--enable-wddx' '--with-tidy' '--with-curl' '--with-iconv' '--with-gmp' '--with-pspell' '--with-gd' '--with-jpeg-dir=/usr' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--enable-gd-jis-conv' '--with-webp-dir=/usr' '--with-zlib-dir=/usr' '--with-xpm-dir=/usr' '--with-openssl' '--with-pdo-mysql=mysqlnd' '--with-gettext=/usr' '--with-bz2=/usr' '--with-recode=/usr' '--with-mysqli' '--enable-soap' '--enable-phar' '--with-xsl' '--with-xmlrpc' '--with-kerberos' '--enable-posix' '--enable-sockets' '--with-pcre-regex' '--with-libdir=lib64' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--enable-intl' '--with-icu-dir=/usr'

I notice that PHP info says "You are running PHP version: 7.3.11", but the phpinfo output shows "PHP Version 5.6.36". Maybe because I updated Php in terminal outside of CWP.
« Last Edit: December 22, 2019, 05:34:13 PM by nickw »