Author Topic: Nginx & Varnish & Apache with php-fpm --- proxy error AH02454 unix domain socket  (Read 5001 times)

0 Members and 1 Guest are viewing this topic.

Changed over to Nginx & Varnish & Apache. Wanted to try Nginx and php-fpm on a domain with WordPress. Tried PHP7.0, PHP7.1, PHP7.2, PHP7.3. No luck. Getting error when accessing web site.
Searched all over, no complete solution to fix this error:

Code: [Select]
[Thu Apr 23 11:29:31.670753 2020] [proxy_fcgi:error] [pid 8412:tid 139741039154944] [client] AH01079: failed to make connection to backend: httpd-UDS
[Thu Apr 23 11:29:32.075975 2020] [proxy:error] [pid 8413:tid 139740946835200] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /opt/alt/php-fpm71/usr/var/sockets/linuxtwe.sock (*) failed
[Thu Apr 23 11:29:32.076051 2020] [proxy_fcgi:error] [pid 8413:tid 139740946835200] [client] AH01079: failed to make connection to backend: httpd-UDS

I followed the youtube
Still issues. Anyone shed some light this? I really would like to start using Nginx with php-fpm.

Ok, I have finally figured it out, from this post:

Oh damn! It works now!!!
All I did was going to the PHP-FPM selector screen in the GUI panel of CWP - Clicking the yellow recycle icon for reload, didn't work and gave again the error above. But when I clicked the Green right arrow icon for starting PHP-FPM73 - guess what! It worked!

Now to the question - why isn't the service automatically starting after compiling the php version?

The ssh command is:
Code: [Select]
/bin/systemctl start php-fpm73.servce