Author Topic: Email account with + doesn't work anymore  (Read 481 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
Email account with + doesn't work anymore
« on: June 26, 2020, 04:43:27 AM »
I'm not sure since which updates that cause this. It used to work for example me+work@mydomain.com but now it's not working anymore. Is there a way to have this working again?

My email autoresponder app uses that + in the return-path.

Offline
**
Re: Email account with + doesn't work anymore
« Reply #1 on: June 26, 2020, 06:52:16 AM »
Can someone please help me confirm this? I contacted support they said it's working fine. But I have a pro and non-pro version installs and both of them are not working.

Can you guys create an email account with anything+anything@yourdomain.com and see if you can log into it? Please help me confirm. I've tried reported it as possible bug but they said it's my configuration.

Offline
**
Re: Email account with + doesn't work anymore
« Reply #2 on: June 26, 2020, 12:02:38 PM »
AFAIK, a '+' is a reserved character in RFC for email (can't be bothered looking it up for you).
It is often used as a substitute for '@', as in useremail+domain.com.
I suggest that your autoresponder software is the real issue in that it shouldn't rely on that character (for a delimiter?).

Offline
**
Re: Email account with + doesn't work anymore
« Reply #3 on: July 01, 2020, 01:15:59 PM »
@cynique Thank you for your comment.

I was told and tested
Code: [Select]
user+something@domain.com treated as
Code: [Select]
user@domain.com which that's what I want. But CWP doesn't work.

You can try it yourself with gmail.
Code: [Select]
yourusername+something@gmail.com and it should delivers to
Code: [Select]
yourusername@gmail.com. I've tested it with iRedMail too. It works. CWP doesn't.

By the way, CWP version: 0.9.8.994

Offline
**
Re: Email account with + doesn't work anymore
« Reply #4 on: July 01, 2020, 04:43:42 PM »
Quote
yourusername+something@gmail.com
Google is unsurprisingly "doing their own thang" there and likely is doing some remapping process. I wouldn't take that example as a correct industry standard - Google have rules unto themselves; seriously. I think some ISPs do similar 'tricks'.
user+domain.com is supposed to be synonymous with user@domain.com, according to cPanel/WHM but this instruction appears to have been removed in later releases. Go figure.

Ammendment
A quick scour of RFCs actually opens the door in what the standards are. The previously mentioned WHM/cPanel "+" delimiter may have been mentioned to circumvent some now obsoleted email client/server. It stuck in my mind for nearly 20 years, for some reason. :-s
A plus sign may be used in the local part of email and it looks as though CWP might be stripping the wrongly identified illegal character. I don't know without analysing the detail.
My prior comment on email address mapping still stands though. ;)

Bedtime reading: https://tools.ietf.org/rfc/rfc3696.txt (Section 4.3 is of specific interest)
« Last Edit: July 01, 2020, 05:00:42 PM by cynique »

Offline
**
Re: Email account with + doesn't work anymore
« Reply #5 on: July 06, 2020, 06:44:35 AM »
@cynique Thanks again for replying.

Well, I've contacted CWP support and they did said that by default
Code: [Select]
user+something@domain.com are treated as
Code: [Select]
user@domain.com
But it doesn't seem to be working. I am just wondering anyone else tested this.

Offline
**
Re: Email account with + doesn't work anymore
« Reply #6 on: July 07, 2020, 06:03:12 AM »
@cynique

According to this the character + does allowed. https://www.jochentopf.com/email/chars.html