Author Topic: Your PHP installation does not support PostgreSQ  (Read 15592 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Your PHP installation does not support PostgreSQ
« on: April 14, 2015, 03:11:20 PM »
how to fix Your PHP installation does not support PostgreSQL. You need to recompile PHP using the --with-pgsql configure option.?

Re: Your PHP installation does not support PostgreSQ
« Reply #1 on: April 15, 2015, 11:42:45 AM »
1) Login to CWP.

2) Navigate to PHP Settings --> PHP Version Switcher.

3) Select PHP Version and click Next.

4) In "Additional configuration (only for advanced users):" add "--with-pgsql" in new line without quotes and click "start compiler in background".

This will enable phpPgAdmin

Offline
*
Re: Your PHP installation does not support PostgreSQ
« Reply #2 on: April 16, 2015, 03:01:17 AM »
Thanks problem solve.  :)

Offline
*
Re: Your PHP installation does not support PostgreSQ
« Reply #3 on: August 17, 2015, 09:50:13 AM »
I have this same problem. I tried following the instructions but it doesn't work for me.

I looked in the configuration and I found out that "--with-pgsql" is not there. It appears when I click the "start compiler in background", the config is not saving.

Any idea?

Offline
*
Re: Your PHP installation does not support PostgreSQ
« Reply #4 on: July 26, 2022, 07:33:36 AM »
Hi, none of the answer working now a days! Because in 2022 today the panel php setting up system has been changed. When I try switch php there have only on/off php extension not possible to write anything with default php. I already enabled pgsql extension while complied but still seeing that odd message " "Your PHP installation does not support PostgreSQL. You need to recompile PHP using the --with-pgsql configure option.""

How to overcome this situation, does anyone know it?
Biswas Host Ltd

www.biswashost.com

Domain, Hosting, Cloud Hosting, VPS, Dedicated Server,

Web Design, SSL, VPN, Professional Email & More

Offline
***