Author Topic: PHP Version Switcher Deployment Error on CWP.Pro  (Read 1529 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
PHP Version Switcher Deployment Error on CWP.Pro
« on: September 21, 2020, 01:52:37 PM »
I am using CWP.Pro and want update from php 5.6.37 to 7.3.22 using PHP Version Switcher v2 . I have checked the log and found the below error:

Code: [Select]
'ioncube_loader_lin_7.1.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.1.so'
'ioncube_loader_lin_7.1_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.1_ts.so'
'ioncube_loader_lin_7.2.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.2.so'
'ioncube_loader_lin_7.2_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.2_ts.so'
'ioncube_loader_lin_7.3.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.3.so'
'ioncube_loader_lin_7.3_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.3_ts.so'
'ioncube_loader_lin_7.4.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.4.so'
'ioncube_loader_lin_7.4_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.4_ts.so'
'loader-wizard.php' -> '/usr/local/ioncube/loader-wizard.php'
yes: standard output: Broken pipe
yes: write error

Code: [Select]
# php -v
Failed loading /usr/local/ioncube/ioncube_loader_lin_7.3.so:  /usr/local/ioncube/ioncube_loader_lin_7.3.so: undefined symbol: zend_ce_cou
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20131226/memcached.so' - /usr/lt open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20131226/redis.so' - /usr/localhared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20131226/mcrypt.so' - /usr/loca shared object file: No such file or directory in Unknown on line 0
PHP 5.6.37 (cli) (built: Jul 20 2018 06:10:33)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies


Code: [Select]
Notice: Undefined variable: ;%( \'!@(1'[&2 in /usr/local/cwpsrv/htdocs/resources/admin/modules/php_switch_v2.php on line 0
any idea ?
It is newly deployed VPS , CWPpro version: 0.9.8.1008

Offline
*
Re: PHP Version Switcher Deployment Error on CWP.Pro
« Reply #1 on: September 21, 2020, 02:11:46 PM »
another error log :

Code: [Select]
compilation terminated.
make: *** [mailparse.lo] Error 1
/bin/sh /usr/local/src/mailparse-3.1.1/libtool --mode=compile cc  -I. -I/usr/local/src/mailparse-3.1.1 -DPHP_ATOM_INC -I/usr/local/src/mailparse-3.1.1/include -I/usr/local/src/mailparse-3.1.1/main -I/usr/local/src/mailparse-3.1.1 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /usr/local/src/mailparse-3.1.1/mailparse.c -o mailparse.lo
 cc -I. -I/usr/local/src/mailparse-3.1.1 -DPHP_ATOM_INC -I/usr/local/src/mailparse-3.1.1/include -I/usr/local/src/mailparse-3.1.1/main -I/usr/local/src/mailparse-3.1.1 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /usr/local/src/mailparse-3.1.1/mailparse.c  -fPIC -DPIC -o .libs/mailparse.o
In file included from /usr/local/src/mailparse-3.1.1/php_mailparse.h:82:0,
                 from /usr/local/src/mailparse-3.1.1/mailparse.c:24:
/usr/local/src/mailparse-3.1.1/php_mailparse_mime.h:20:43: fatal error: ext/standard/php_smart_string.h: No such file or directory
 #include "ext/standard/php_smart_string.h"
                                           ^
compilation terminated.
make: *** [mailparse.lo] Error 1