Author Topic: Module made with postgresql does not work  (Read 1534 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Module made with postgresql does not work
« on: July 06, 2015, 01:32:23 AM »
Friends, good night;
I am creating a module and need that he has connection to postgresql.
When trying to connect the following error occurred:

Fatal error: Call to undefined function pg_connect ()

The PHP postgre is not enabled, this value does not appear in phpinfo ().

The CWP is with postgre working, use the phppgadmin normally.
I believe that for the ADMIN area is not enabled pgsql php module.
How can I enable this module for ADM area properly?
Thanks.
« Last Edit: July 09, 2015, 06:04:39 PM by Marcelo »

Offline
*
Re: Module made with postgresql does not work
« Reply #1 on: July 14, 2015, 03:50:16 AM »
How no one helped me, I had to research and work alone.
Here's the solution to my problem, I had to recompile the php that was used for the ADM area.

So others do not go through what I went through:

Code: [Select]
/usr/local/src/cwp/php-5.4.27/configure --with-apxs2=/usr/local/cwpsrv/bin/apxs --prefix=/usr/local/cwp/php54 --with-config-file-path=/usr/local/cwp/php54 --with-config-file-scan-dir=/usr/local/cwp/php54/php.d --with-libdir=lib --with-mysql --with-mysqli --enable-mbstring --disable-debug --disable-rpath --with-bz2 --with-curl --with-gettext --with-iconv --with-openssl --with-gd --with-mcrypt --with-pcre-regex --with-zlib --with-mysql-sock=/var/lib/mysql/mysql.sock --with-pgsql