Author Topic: No Permissions in NextCloud  (Read 2050 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
No Permissions in NextCloud
« on: February 19, 2018, 02:20:55 PM »
Hello,

I installed the nextcloud via softaculous, and I updated your pro version of cwp (it is not yet active), the problem is that when starting Nextcloud, does not appear folders or files in the site.

And when I try to create a folder or send a file says that I do not have permissions to do so. Can anyone help?

I've already tried putting the data folder to 777 but it still does not work

Thanks

Offline
****
Re: No Permissions in NextCloud
« Reply #1 on: February 19, 2018, 06:12:55 PM »

Offline
*
Re: No Permissions in NextCloud
« Reply #2 on: February 19, 2018, 06:16:57 PM »
Yes I have tried but don't work :/

Offline
****
Re: No Permissions in NextCloud
« Reply #3 on: February 19, 2018, 06:17:36 PM »
any screenshot you can show of error?

Offline
*
Re: No Permissions in NextCloud
« Reply #4 on: February 19, 2018, 06:36:55 PM »
Only have a notification say: "You don't have permission to upload or create files here", and in first page are in blank when have start installer filles and images.

Yesterday I tried use the vestacp and works, but I use the cwp a long time and like it...  :'(

Offline
****
Re: No Permissions in NextCloud
« Reply #5 on: February 19, 2018, 06:39:32 PM »
Did you check file permission are they owned by correct users?

Offline
*
Re: No Permissions in NextCloud
« Reply #6 on: February 19, 2018, 06:46:24 PM »
I think so, it was the softaculous that installed via cwp and I'm logging in with the nextcloud admin account

Offline
****
Re: No Permissions in NextCloud
« Reply #7 on: February 19, 2018, 06:50:17 PM »
something you can find in apache error log?

Offline
*
Re: No Permissions in NextCloud
« Reply #8 on: February 19, 2018, 07:02:26 PM »
In this moment I have this warnings in admin panel of nextcloud:
https://ibb.co/jXsORS
This is what happens when I try to delete notifications on the right side of the screen:
https://ibb.co/hitV6S
When I drag files to upload, this happens (Translation:You don't have permission to upload or create files here):
https://ibb.co/f5usLn

How can I see the logs in cwp panel (I'm not home)?

Offline
*
Re: No Permissions in NextCloud
« Reply #9 on: February 20, 2018, 01:15:21 AM »
I've been able to solve the problem. It was webdav that was not working. I solved the problem the way I found it here in the forum:

Step 1:

You can edit httpd.conf (from Apache Configuration in "Apache Settings")

Search modules and uncomment the lines (include)

Quote
LoadModule alias_module modules/mod_alias.so
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authn_core_module modules/mod_authn_core.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule authz_user_module modules/mod_authz_core.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule dav_module modules/mod_dav.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule dav_lock_module modules/mod_dav_lock.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule setenvif_module modules/mod_setenvif.so

LoadModule expires_module modules/mod_expires.so
LoadModule headers_module modules/mod_headers.so

Step 2:

Code: [Select]
/usr/local/apache/bin/httpd -M | grep -i dav
Quote
Syntax OK
  dav_module (static)
  dav_fs_module (static)
  dav_lock_module (static)

If you show like this, okey go to step 3

Step 3:

Code: [Select]
/usr/local/apache/conf/extra/httpd-userdir.conf

Replace with these codes:

Code: [Select]
<Directory "/home/*/public_html">
  AllowOverride FileInfo AuthConfig Limit Indexes
  Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
  <Limit GET POST OPTIONS>
  Order allow,deny
  Allow from all
  </Limit>
  <LimitExcept GET POST OPTIONS>
  Order deny,allow
  Deny from all
  </LimitExcept>
</Directory>

Step 4: (for Nextcloud/Owncloud and other cloud app)

Code: [Select]
/home/USERNAME/public_html/nextcloud/.htaccess
Add the bottom of the page

Code: [Select]
<Limit GET POST>
  order deny,allow
  allow from all
</Limit>
<Limit PUT DELETE>
  order deny,allow
  allow from all
</Limit>

Step 5:

Code: [Select]
systemctl restart httpd

Offline
*
Re: No Permissions in NextCloud
« Reply #10 on: December 01, 2018, 02:33:31 AM »
Sorry for bumping this old topic. I'll start a new one if necessary.

I tried the last suggestions above, but the mod_dav_lock.so module is missing from my Apache config and is not present in the modules folder.

Do I need to recompile Apache with mod_dav_lock.so?
« Last Edit: December 01, 2018, 03:02:07 AM by adxp »