Author Topic: Trying to Install Lets Encrypt, but getting errors  (Read 446 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Trying to Install Lets Encrypt, but getting errors
« on: March 09, 2017, 05:06:59 PM »
Hi

Thanks to firefox 51 showing insecure message when users login, it has forced me to add ssl to site login.
Lets Encrypt would seem to be the preferred option for me, but following the vid instruction. I can only get so far
When I click install certificate the following error message appears.

Bootstrapping dependencies for RedHat-based OSes...
yum is /usr/bin/yum
Package gcc-4.4.7-17.el6.x86_64 already installed and latest version
Package redhat-rpm-config-9.0.3-51.el6.centos.noarch already installed and latest version
Package ca-certificates-2015.2.6-65.0.1.el6_7.noarch already installed and latest version
Package python-2.6.6-66.el6_8.x86_64 already installed and latest version
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
The program yum-complete-transaction is found in the yum-utils package.
Error: python-devel conflicts with python-2.6.6-64.el6.x86_64
 You could try using --skip-broken to work around the problem
** Found 17 pre-existing rpmdb problem(s), 'yum check' output follows:
MariaDB-client-10.1.18-1.el6.x86_64 is a duplicate with MariaDB-client-10.1.16-1.el6.x86_64
MariaDB-common-10.1.18-1.el6.x86_64 is a duplicate with MariaDB-common-10.1.16-1.el6.x86_64
MariaDB-compat-10.1.18-1.el6.x86_64 is a duplicate with MariaDB-compat-10.1.16-1.el6.x86_64
MariaDB-server-10.1.18-1.el6.x86_64 is a duplicate with MariaDB-server-10.1.16-1.el6.x86_64
MariaDB-shared-10.1.18-1.el6.x86_64 is a duplicate with MariaDB-shared-10.1.16-1.el6.x86_64
32:bind-libs-9.8.2-0.47.rc1.el6_8.1.x86_64 is a duplicate with 32:bind-libs-9.8.2-0.47.rc1.el6.x86_64
32:bind-utils-9.8.2-0.47.rc1.el6_8.1.x86_64 is a duplicate with 32:bind-utils-9.8.2-0.47.rc1.el6.x86_64
cronie-1.4.4-16.el6_8.2.x86_64 is a duplicate with cronie-1.4.4-15.el6_7.1.x86_64
cronie-anacron-1.4.4-16.el6_8.2.x86_64 is a duplicate with cronie-anacron-1.4.4-15.el6_7.1.x86_64
galera-25.3.18-1.rhel6.el6.x86_64 is a duplicate with galera-25.3.15-1.rhel6.el6.x86_64
grep-2.20-5.el6_8.x86_64 is a duplicate with grep-2.20-3.el6_7.1.x86_64
1:net-snmp-5.5-57.el6_8.1.x86_64 is a duplicate with 1:net-snmp-5.5-57.el6.x86_64
1:net-snmp-libs-5.5-57.el6_8.1.x86_64 is a duplicate with 1:net-snmp-libs-5.5-57.el6.x86_64
openssl-1.0.1e-48.el6_8.3.i686 is a duplicate with openssl-1.0.1e-48.el6_8.1.x86_64
python-2.6.6-66.el6_8.x86_64 is a duplicate with python-2.6.6-64.el6.x86_64
python-libs-2.6.6-66.el6_8.x86_64 is a duplicate with python-libs-2.6.6-64.el6.x86_64
udev-147-2.73.el6_8.2.x86_64 is a duplicate with udev-147-2.73.el6.x86_64
Could not install OS dependencies. Aborting bootstrap!

Offline
*
Re: Trying to Install Lets Encrypt, but getting errors
« Reply #1 on: March 13, 2017, 08:39:37 AM »
try this:

yum clean all
rpm --rebuilddb
yum update

or

rpm --rebuilddb
yum clean all
yum update

and try again

Offline
*
Re: Trying to Install Lets Encrypt, but getting errors
« Reply #2 on: March 14, 2017, 12:01:39 AM »
Hi

Thanks for your help, that definitely helped in solving the problem, after I had updated via yum, and tried the install again, I had further errors that were pointing to running yum-complete-transcation, when i tried this i get error no such command so had to run
yum install-yum utils
and then run yum-complete-transcation, once this had completed, i could then complete the certificate as per the video.

Offline
**
Re: Trying to Install Lets Encrypt, but getting errors
« Reply #3 on: April 25, 2017, 06:31:59 PM »
Which version of centos are you using?