Author Topic: WHMCS installing issue  (Read 477 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
WHMCS installing issue
« on: November 08, 2018, 07:49:28 AM »
Hello.

I have trouble installing whmcs at very start. could you point out exactly where should cwp7.php upload? i cant find WHMCS/modules/servers/cwp7/cwp7.php that path or am i missing something? is there something else i must do? with file manager i cant find that path, do i need preinstall it first? how?

Thank you

best regards

Offline
*
Re: WHMCS installing issue
« Reply #1 on: November 14, 2018, 11:34:41 AM »
http://wiki.centos-webpanel.com/whmcs-module-for-cwp-api

1. Extract file cwp7.zip in your whmcs folder
WHMCS/modules/servers/

as extracted module file path will look like this
WHMCS/modules/servers/cwp7/cwp7.php

2. In WHMCS
In Menu goto: Setup -> Products/Services -> Servers
Add New Server and under “Server Details”
Type = Cwp7
Username: root
Password: (your server password)
Access Hash: copy your key from CWP API

3. Generate API Key on the CWP server
goto Left-Menu -> CWP Settings -> API Manager
Use the following permissions:
-add, edit, suspend, unsuspend and delete accounts
-edit packages
-change Password

Offline
*
Re: WHMCS installing issue
« Reply #2 on: November 18, 2018, 02:01:15 PM »
http://wiki.centos-webpanel.com/whmcs-module-for-cwp-api

1. Extract file cwp7.zip in your whmcs folder
WHMCS/modules/servers/

 Password

This does work to un-suspend, delete, create etc, But the user can not login from WHMCS Billing side.
The link in admin side WHMCS, while looking at users service to open CWP is also wrong.
I use it but users keep asking, "Why can I not log in from my WHMCS billing to my CWP Panel it shows 404?"
It seems an easy fix ?

Greets 
« Last Edit: November 18, 2018, 02:07:24 PM by Jason »

Offline
*
Re: WHMCS installing issue
« Reply #3 on: November 25, 2018, 09:38:17 PM »
just to be sure, in you CWP's [API] panel area, did you use a parenthesis? (" % ")  in the "IP Origin" field..

i had the same problem, and i contacted CWP Support, and that fixed it for me.

Hope it helps.

Use the [SEARCH] in CWP for "API":

Api access management
Short Name    Ip Origin    Key code    Request / Answer    Actions
cwpwhmcs    %            -------------   -----------    ----------       ----------


Offline
*
Re: WHMCS installing issue
« Reply #4 on: November 26, 2018, 07:34:56 PM »
just to be sure, in you CWP's [API] panel area, did you use a parenthesis? (" % ")  in the "IP Origin" field..

i had the same problem, and i contacted CWP Support, and that fixed it for me.

Hope it helps.


Thank You  ;D it does not log in automatically but at least now, its at the correct login link.
Much appreciated  x1705