Author Topic: Apache 2.4.23 (and .25) Timeout hardcoded?  (Read 666 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Apache 2.4.23 (and .25) Timeout hardcoded?
« on: June 10, 2017, 07:45:02 AM »
Hello,
i have a long running php script that imports CSV files (it runs about 5-7 minutes).
In php.ini there is

max_execution_time = 900
max_input_time = 900
memory_limit = 1024M
default_socket_timeout = 900

and in httpd.conf there is
Timeout 60 (default setting)

But every time script times out exactly 120 seconds after start. I tried putting Timeout 300 in httpd-default.conf, but nothing happens, still throwing error 500 (script timed out before returning headers) every time.

Somewhere i have read that apache has hardcoded timeout for php-fpm, but im using suPHP (cwp default apache installation) and i cannot find the problem.

Anyone knows the solution?


Best regards

Offline
*
Re: Apache 2.4.23 (and .25) Timeout hardcoded?
« Reply #1 on: June 10, 2017, 07:13:48 PM »
do you have only apache as web server and have you restarted it after changing settings ?
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Apache 2.4.23 (and .25) Timeout hardcoded?
« Reply #2 on: June 11, 2017, 08:34:44 AM »
Yes, Apache only.
I tried on 2 VPS-es, both with latest CWP. Every time, after 120 seconds the process timeouts with the same error.
I doubt that it has something to do with fcgi (since in phpinfo it says that server api is cgi/fastcgi) but afaik CWP compiles Apache with suPHP 0.7.2?
Also, i dont see fcgi in loaded modules, but it still keeps timing out after 120 seconds.

Any other ideas?