Author Topic: Error 500 Internal Server Error on virtual host  (Read 1148 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Error 500 Internal Server Error on virtual host
« on: January 07, 2019, 04:50:47 PM »
in fresh install of Centos 7 I create a account with name tpelek.
when I visit vhost http://IP/~tpelek/ i receive error 500 Internal Server Error
in error log write : home/tpelek/public_html/.htaccess: Options not allowed here

if I visit the main http://IP/ works ok.

in both directories I have the default joomla .htaccess but the problem only in vhost.
If I comment out from .htaccess Options +FollowSymlinks and Options -Indexes I don't receive any error.

I try to fix account permissions and usr / local / apache / conf.d / vhosts / tpelek.com.conf have the option

   <Directory "/home/tpelek/public_html">
      AllowOverride All
   </Directory>

in server I build before 2-3 months with centos 7 this not happen.

Thanks in advanced
Thodoris

Offline
**
Re: Error 500 Internal Server Error on virtual host
« Reply #1 on: January 07, 2019, 07:44:02 PM »
What PHP handler are you using?

Offline
*
Re: Error 500 Internal Server Error on virtual host
« Reply #2 on: January 11, 2019, 10:30:34 AM »
What PHP handler are you using?

Sorry for my late reply, I guess is CGI , I didn't do any change , just fresh install


Offline
*
Re: Error 500 Internal Server Error on virtual host
« Reply #3 on: January 11, 2019, 12:44:57 PM »
you should check what you have in htaccess file or you can try to forward subdomain/domain to that location and test like that or with modifications of the hosts file.
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: Error 500 Internal Server Error on virtual host
« Reply #4 on: January 11, 2019, 01:53:32 PM »
htaccess is the standard file from joomla

If I delete from htaccess these two "options +FollowSymlinks and Options -Indexes" I don't receive error

This happen only on vhost.
I try to FW a domain as you suggest but I don't think this will works.

Offline
*
Re: Error 500 Internal Server Error on virtual host
« Reply #5 on: January 12, 2019, 05:09:58 PM »
you should check what you have in htaccess file or you can try to forward subdomain/domain to that location and test like that or with modifications of the hosts file.

you are right, I point the domain and works with out error.
there is any way to access from IP/~account or hostname/~account name ?

Thanks

Offline
*
Re: Error 500 Internal Server Error on virtual host
« Reply #6 on: January 14, 2019, 08:19:56 AM »
you would need to check error_log it's probably suPHP security restriction which would then require custom conf.
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: Error 500 Internal Server Error on virtual host
« Reply #7 on: January 14, 2019, 03:35:17 PM »
the error in error_log is "public_html/.htaccess: Options not allowed here"
the suphp_log haven't any error.

Thanks

Offline
*
Re: Error 500 Internal Server Error on virtual host
« Reply #8 on: January 15, 2019, 08:28:02 AM »
then remove options from htaccess
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: Error 500 Internal Server Error on virtual host
« Reply #9 on: January 24, 2019, 01:25:16 AM »
Same problem here.
Tried every single "solution" in this forum..
Unsuccessfull :/

*no log errors..

I can give teamviewer access if anybody offers to help me.

Regards
« Last Edit: January 24, 2019, 01:27:55 AM by yamano »

Offline
*
Re: Error 500 Internal Server Error on virtual host
« Reply #10 on: January 24, 2019, 09:40:32 PM »
if you find a solution please share it
thanks