Author Topic: ERROR APACHE WEBSERVER  (Read 1015 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
ERROR APACHE WEBSERVER
« on: April 03, 2018, 03:09:38 AM »
Hi,

I'm using CWP Pro, but I cannot to setup Apache & Varnish Cache & Nginx Reverse Proxy or Apache & Nginx Reverse Proxy.

Error:

Warning: file_put_contents(/etc/nginx/conf.d/103.9.xxx.xxx.conf): failed to open stream: No such file or directory in /usr/local/cwpsrv/htdocs/resources/admin/include/hooks.php on line 0

Please help me! Many thanks.

Offline
*
Re: ERROR APACHE WEBSERVER
« Reply #1 on: April 04, 2018, 01:52:57 PM »
I have same issue... :'(
Can anyone help?

Offline
*
Re: ERROR APACHE WEBSERVER
« Reply #2 on: April 04, 2018, 06:58:28 PM »
After a little debugging i found the issue. It seems that if you change php with "PHP Version Switcher" even if you compile the new php with "ioncube" enabled, the enconded content of "usr/local/cwpsrv/htdocs/resources/admin/include/hooks.php" file cannot be read with the new version.

kortibu, use "curl http://dl1.centos-webpanel.com/files/s_scripts/sinfo.sh|sh" and see what is the problem at your side...

Offline
*
Re: ERROR APACHE WEBSERVER
« Reply #3 on: April 06, 2018, 05:29:01 AM »
c1audiu: thank you so much, now i knew the raison of this error. So, should we to remove ioncube while compiling PHP Version or to upgrade Ioncube version???

Offline
*
Re: ERROR APACHE WEBSERVER
« Reply #4 on: April 06, 2018, 05:30:33 AM »
My error on SSH: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/resources/scripts/cwp_version was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1.

Offline
*****
Re: ERROR APACHE WEBSERVER
« Reply #5 on: April 11, 2018, 06:40:29 PM »
My error on SSH: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/resources/scripts/cwp_version was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1.

Hello.

Try to install ionCube for your PHP version