Author Topic: Fail to install mod_evasive  (Read 503 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Fail to install mod_evasive
« on: July 12, 2018, 08:02:27 PM »
Hi, i need to install mod_evasive, but i got protected multilib error installing it from EPEL...
Anyone knows how to solve it?

Follow the error
Code: [Select]
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for apr which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of apr of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude apr.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of apr installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of apr installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: apr-1.3.9-5.el6_9.1.i686 != apr-1.6.2-1.x86_64
Error: Protected multilib versions: apr-util-1.3.9-3.el6_0.1.i686 != apr-util-1.6.0-1.x86_64


Offline
***
Re: Fail to install mod_evasive
« Reply #1 on: July 13, 2018, 07:25:56 AM »
What's the output of yum update command?
https://www.24x7servermanagement.com/
Server Management, Server Security, Server Monitoring.
India's Leading Managed Service Provider !!

Offline
*
Re: Fail to install mod_evasive
« Reply #2 on: July 16, 2018, 12:32:40 PM »
Hi, follows the output.

Code: [Select]
[root@cwp ~]# yum install --enablerepo=epel mod_evasive
Loaded plugins: fastestmirror, protectbase
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.nbtelecom.com.br
 * extras: mirror.nbtelecom.com.br
 * updates: mirror.nbtelecom.com.br
0 packages excluded due to repository protections
Resolving Dependencies
--> Running transaction check
---> Package mod_evasive.x86_64 0:1.10.1-10.el6 will be installed
--> Processing Dependency: httpd-mmn = 20051115 for package: mod_evasive-1.10.1-10.el6.x86_64
--> Processing Dependency: httpd for package: mod_evasive-1.10.1-10.el6.x86_64
--> Running transaction check
---> Package httpd.x86_64 0:2.2.15-69.el6.centos will be installed
--> Processing Dependency: httpd-tools = 2.2.15-69.el6.centos for package: httpd-2.2.15-69.el6.centos.x86_64
--> Processing Dependency: apr-util-ldap for package: httpd-2.2.15-69.el6.centos.x86_64
--> Running transaction check
---> Package apr-util-ldap.x86_64 0:1.3.9-3.el6_0.1 will be installed
--> Processing Dependency: apr-util = 1.3.9-3.el6_0.1 for package: apr-util-ldap-1.3.9-3.el6_0.1.x86_64
---> Package httpd-tools.x86_64 0:2.2.15-60.el6.centos.4 will be updated
---> Package httpd-tools.x86_64 0:2.2.15-69.el6.centos will be an update
--> Running transaction check
---> Package apr-util.i686 0:1.3.9-3.el6_0.1 will be installed
--> Processing Dependency: libuuid.so.1 for package: apr-util-1.3.9-3.el6_0.1.i686
--> Processing Dependency: libexpat.so.1 for package: apr-util-1.3.9-3.el6_0.1.i686
--> Processing Dependency: libapr-1.so.0 for package: apr-util-1.3.9-3.el6_0.1.i686
--> Running transaction check
---> Package apr.i686 0:1.3.9-5.el6_9.1 will be installed
---> Package expat.i686 0:2.0.1-13.el6_8 will be installed
---> Package libuuid.x86_64 0:2.17.2-12.28.el6_9.1 will be updated
--> Processing Dependency: libuuid = 2.17.2-12.28.el6_9.1 for package: libblkid-2.17.2-12.28.el6_9.1.x86_64
--> Processing Dependency: libuuid = 2.17.2-12.28.el6_9.1 for package: util-linux-ng-2.17.2-12.28.el6_9.1.x86_64
--> Processing Dependency: libuuid = 2.17.2-12.28.el6_9.1 for package: libuuid-devel-2.17.2-12.28.el6_9.1.x86_64
---> Package libuuid.i686 0:2.17.2-12.28.el6_9.2 will be installed
---> Package libuuid.x86_64 0:2.17.2-12.28.el6_9.2 will be an update
--> Running transaction check
---> Package libblkid.x86_64 0:2.17.2-12.28.el6_9.1 will be updated
---> Package libblkid.x86_64 0:2.17.2-12.28.el6_9.2 will be an update
---> Package libuuid-devel.x86_64 0:2.17.2-12.28.el6_9.1 will be updated
---> Package libuuid-devel.x86_64 0:2.17.2-12.28.el6_9.2 will be an update
---> Package util-linux-ng.x86_64 0:2.17.2-12.28.el6_9.1 will be updated
---> Package util-linux-ng.x86_64 0:2.17.2-12.28.el6_9.2 will be an update
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for apr which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of apr of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude apr.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of apr installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of apr installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: apr-1.3.9-5.el6_9.1.i686 != apr-1.6.2-1.x86_64
Error: Protected multilib versions: apr-util-1.3.9-3.el6_0.1.i686 != apr-util-1.6.0-1.x86_64
[root@cwp ~]#

Offline
****
Re: Fail to install mod_evasive
« Reply #3 on: July 16, 2018, 08:39:28 PM »
Dont use yum to install it.

Code: [Select]
git clone https://github.com/shivaas/mod_evasive.git
cd mod_evasive
/usr/local/apache/bin/apxs -i -a -c mod_evasive24.c


Code: [Select]
nano /usr/local/apache/conf.d/mod_evasive.conf
enter the content below.

Quote
<IfModule mod_evasive24.c>
DOSHashTableSize 3097
DOSPageCount 2
DOSSiteCount 50
DOSPageInterval 1
DOSSiteInterval 1
DOSBlockingPeriod 60
DOSEmailNotify <youremailaddresshere>
</IfModule>

Change settings as per your need.
« Last Edit: July 16, 2018, 09:27:14 PM by bullten »

Offline
*
Re: Fail to install mod_evasive
« Reply #4 on: July 17, 2018, 11:51:53 AM »
Thanks! It works!

Now I'm fighting with email notification, I have Postfix (configured with my SMTP server) and the e-mail sent has no subject.
Any hint about this?