Author Topic: httpd error log says Options not allowed here  (Read 6689 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
httpd error log says Options not allowed here
« on: April 17, 2015, 10:14:15 AM »
I'm a kind of newbie here, but I've been reading every related post to my Apache problem in the forum and also google provides help from some other places
The problem is simple: i've got a Joomla app installation that refuses to run because in the .htaccess includes
Code: [Select]
Options +FollowSymlinks
Options -Indexes
in order to make work the mod_rewrite php module so friendly URL are displayed in the browser.
But the httpd error log file says Options not allowed here...
In the vhost config file there's
Code: [Select]
<Directory "/home/musgoevents/public_html">
        AllowOverride All
</Directory>
Is there any other directive conf file after vhost.conf that is overrinding this <directory> configuration?
Any clue?



Offline
*
Re: httpd error log says Options not allowed here
« Reply #1 on: April 17, 2015, 12:28:24 PM »
hi im using wordpress and .htaccess use mod_rewrite, im using a clean cwp instance and it works propertly whitout any additional config

Code: [Select]
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /blog
RewriteCond $1 !^(index\.php|images|robots\.txt)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?/$1 [L,QSA]
</IfModule>

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /blog/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /blog/index.php [L]
</IfModule>
# END WordPress

Offline
*
Re: httpd error log says Options not allowed here
« Reply #2 on: April 17, 2015, 10:41:15 PM »
I've not tried yet a Wordpress app, but 99% of my hosts are Joomla so your info is not very helpful for me. :'(
Thanks.

Offline
*
Re: httpd error log says Options not allowed here
« Reply #3 on: April 18, 2015, 05:38:39 PM »
Some news. I've managed to solve the problem.
I'm almost 99% sure that vhost.conf is not being loaded in httpd.conf.

As I understand this code at the end of httpd.conf file
Code: [Select]
Include /usr/local/apache/conf.d/*.conf
should include ALL conf files in that folder, that is to say:
domain-redirects.conf
empty.conf
server-status.conf
suphp.conf
system-redirects.conf
vhosts.conf

but I think there's something wrong and no files are included.

So i've included manually at the end of httpd.conf by inserting...
Code: [Select]
Include /usr/local/apache/conf.d/vhosts.conf
and it works. I can visit the home page but I can't browse to a menu (diferent addresses) then
Code: [Select]
No user or group set - set suPHP_UserGroup, referer: http://xxx.xxx.xxx.xxx/~musgoeve/

Any clues? :'(
« Last Edit: April 19, 2015, 11:25:11 AM by llamaza »

Re: httpd error log says Options not allowed here
« Reply #4 on: April 23, 2015, 07:03:21 AM »
Hello,

I did a test install and it seems to be working fine. There is no need to change anything

http://cwp.bullten.com/joomla

Offline
*
Re: httpd error log says Options not allowed here
« Reply #5 on: April 23, 2015, 09:28:22 PM »
Hi Bullten,

Thanks for your comment, but your Joomla installation is not rewritting the URL. Please could you activate it from the Global configuration inside Joomla backpanel (administrator) You also need to rename the htaccess.txt file provided as default to .htaccess.

Then we could check the whole thing again.

Thanks again.


Re: httpd error log says Options not allowed here
« Reply #6 on: April 24, 2015, 01:25:18 AM »

Offline
*
Re: httpd error log says Options not allowed here
« Reply #7 on: April 24, 2015, 10:29:38 AM »
It works :o
could you post your vhost.conf file or template, please?

Re: httpd error log says Options not allowed here
« Reply #8 on: April 24, 2015, 11:40:34 PM »
Everything is default, we didnt change anything.