Author Topic: Backup Issue  (Read 409 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Backup Issue
« on: February 03, 2018, 03:02:18 PM »
Hey guys.  I can't find any documentation so I will post it here.

I have enabled automatic backups (daily, weekly, monthly).  However, if I log in as a user (domain.com:2083) then go to File Management -> Backup, I get a message just below the "Download a full website backup" saying "Currently, there is no automatically generated backup available. The administrator of the server owner must enable this function.".  However, I do have this enabled.

2nd, if I download a full website backup, it then shows below as a backup_datexxx.tar.gz, but the icon on the left side (cloud wiht down arrow) is not clickable and I cannot click the backup to download it to my pc.  Do I need to FTP as an account user to be able to download the backup?  But there is a button to delete the backup.

Please advise.  I want to make sure all users have automated backups, but the message that shows up when logged in as user does not give any confidence as it says there are no backups....


Offline
*
Re: Backup Issue
« Reply #1 on: February 03, 2018, 03:03:43 PM »
Also, for the automated backups configured at server admin level, they are not .tar.gz, so how can we use it to restore an account?

Offline
*
Re: Backup Issue
« Reply #2 on: February 13, 2018, 05:44:45 PM »
Same here...

Tried to make a backup on demo machine - enabling all backup options in root section and then i ran

Code: [Select]
/usr/local/cwp/php71/bin/php -d max_execution_time=1000000 -q /usr/local/cwpsrv/htdocs/resources/admin/include/cron_backup.php
Everything seem fine in log
Code: [Select]
###############################################
Daily Files Backup starting
###############################################
Username: testacc
========================================
sending incremental file list
sent 336 bytes  received 18 bytes  708.00 bytes/sec
total size is 5539  speedup is 15.65
Username: cwppro
========================================
sending incremental file list
sent 145 bytes  received 13 bytes  316.00 bytes/sec
total size is 5511  speedup is 34.88
Username: cwphost
========================================
sending incremental file list
sent 338 bytes  received 17 bytes  710.00 bytes/sec
total size is 955606511  speedup is 2691849.33
Username: testcwp
========================================
sending incremental file list
sent 145 bytes  received 13 bytes  316.00 bytes/sec
total size is 5511  speedup is 34.88
###############################################
Daily Files Backup finished
###############################################
###############################################
Daily MySQL Backup starting
###############################################
Skipping database: information_schema.
Database Backup: mysql --> /backup/mysql/daily//mysql.sql
Database Backup: oauthv2 --> /backup/mysql/daily//oauthv2.sql
mysqldump: Got error: 1142: "SELECT, LOCK TABLES command denied to user 'root'@'localhost' for table 'accounts'" when using LOCK TABLES
Database Backup: performance_schema --> /backup/mysql/daily//performance_schema.sql
Database Backup: postfix --> /backup/mysql/daily//postfix.sql
Database Backup: root_cwp --> /backup/mysql/daily//root_cwp.sql
Database Backup: roundcube --> /backup/mysql/daily//roundcube.sql
curl: (7) Failed connect to dl1.centos-webpanel.com:80; Connection timed out
error: skipping http://dl1.centos-webpanel.com/files/mysql/percona-toolkit.rpm - transfer failed
###############################################
Daily MySQL Backup finished
###############################################

But when i look into testacc account, there is still message: "Currently, there is no automatically generated backup available. The administrator or the server owner must enable this function."

Can't say what is the problem, same symptoms on my machine, even on the demo machine, i'll try contact support.
« Last Edit: February 13, 2018, 06:22:49 PM by KanibalCz »

Offline
*
Re: Backup Issue
« Reply #3 on: February 13, 2018, 06:24:09 PM »
As far as I understand, the backup of the administrator has nothing to do with the backup generated by the users

For once you generate your backup as a user, you can download it in / home / USER / backupcwp / via ftp

Offline
*
Re: Backup Issue
« Reply #4 on: February 13, 2018, 06:40:34 PM »
If you log into https://79.137.25.230:2083/testacc/?module=backups - you'll see that there is a message: "Currently, there is no automatically generated backup available. The administrator or the server owner must enable this function."

in the attached log file above you can see, that there is backup of every user in CWP. But in the user panel section you can't see the automatic generated backups.
« Last Edit: February 13, 2018, 06:43:43 PM by KanibalCz »

Offline
*
Re: Backup Issue
« Reply #5 on: February 13, 2018, 07:01:26 PM »
what happens if you click the generate button now

Offline
*
Re: Backup Issue
« Reply #6 on: February 13, 2018, 07:07:37 PM »
If you mean "Download a full website backup" - if you click it, the backup generates - that's ok and it's working.

But i need automatic backups (daily, weekly, monthly). Guess we're both talking about something different :(

Offline
*
Re: Backup Issue
« Reply #7 on: February 13, 2018, 07:19:43 PM »
Automatic backups are the property of the administrator only where they are

Offline
*
Re: Backup Issue
« Reply #8 on: February 13, 2018, 07:22:15 PM »
Used to be in previous versions. But in the new update, they let user see status of automatic backups.

Offline
*
Re: Backup Issue
« Reply #9 on: February 13, 2018, 10:56:08 PM »
user can see only info about his manual backups, admin backups can go on the different locations.
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: Backup Issue
« Reply #10 on: February 14, 2018, 10:41:58 PM »
Why do you have in user panel section under backups this message then?

"Currently, there is no automatically generated backup available. The administrator or the server owner must enable this function."