Author Topic: CentOS admin not loading - forgot port ?  (Read 674 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
CentOS admin not loading - forgot port ?
« on: February 19, 2018, 02:29:53 PM »
Hi,

I have an old CWP installation, couple of websites running on it and all are fine. It seems either I have forgotten port for admin or cwp admin is not loading .

I checked  version, its :
Code: [Select]
cat /usr/local/cwpsrv/htdocs/resources/admin/include/version.php
<?php
$webpanel_version 
"0.9.8.314";
?>


I restarted cwp :
Code: [Select]
service cwpsrv restart
Stopping cwpsrv:                                           [  OK  ]
Starting cwpsrv:                                         [ OK ]

But its just not loading if I try : http://my-server-ip:2030 or https://my-server-ip:2031.

I also tried after disabling csf -x

Also tried
"service iptables stop"

But can't seems to get GUI work.

Browser is saying that "Site can't be reached" , so I checked my server-ip, its pingable and site hosted on it are working fine.

So, how can I verify on which port CWP admin is running and whether its running at all ?


Offline
****
Re: CentOS admin not loading - forgot port ?
« Reply #1 on: February 19, 2018, 02:42:10 PM »
from SSH CLI run
Code: [Select]
netstat -plnt
look for listening port of
Quote
cwpsrv: master

Offline
*
Re: CentOS admin not loading - forgot port ?
« Reply #2 on: February 19, 2018, 03:52:50 PM »
from SSH CLI run
Code: [Select]
netstat -plnt
look for listening port of
Quote
cwpsrv: master

Thanks,

This is what I get :

Code: [Select]
netstat -plnt | grep cwpsrv
tcp        0      0 127.0.0.1:2302              0.0.0.0:*                   LISTEN      2246/cwpsrv
tcp        0      0 0.0.0.0:2082                0.0.0.0:*                   LISTEN      2246/cwpsrv
tcp        0      0 0.0.0.0:2083                0.0.0.0:*                   LISTEN      2246/cwpsrv
tcp        0      0 0.0.0.0:2086                0.0.0.0:*                   LISTEN      2246/cwpsrv
tcp        0      0 0.0.0.0:2087                0.0.0.0:*                   LISTEN      2246/cwpsrv
tcp        0      0 0.0.0.0:2030                0.0.0.0:*                   LISTEN      2246/cwpsrv
tcp        0      0 0.0.0.0:2095                0.0.0.0:*                   LISTEN      2246/cwpsrv
tcp        0      0 0.0.0.0:2031                0.0.0.0:*                   LISTEN      2246/cwpsrv
tcp        0      0 0.0.0.0:2096                0.0.0.0:*                   LISTEN      2246/cwpsrv
[/quote]


Offline
****
Re: CentOS admin not loading - forgot port ?
« Reply #3 on: February 19, 2018, 04:32:41 PM »
cwpsrv appears online then. Did you try the all ports except for 2302? Check the webrowser console for any error

Offline
*
Re: CentOS admin not loading - forgot port ?
« Reply #4 on: February 22, 2018, 02:22:34 PM »
This is weirdo ...

Can you tell me if I wish to change cwp ports, then from where I can do it correctly ?


Offline
*
Re: CentOS admin not loading - forgot port ?
« Reply #6 on: February 25, 2018, 06:09:17 PM »
http://forum.centos-webpanel.com/how-to/how-to-change-cwpsrvd-listen-port-(cwp)/

Have been there multiple times, its an old post, I suppose now CWP uses nginx instead of apache. So obviously its leads no where.

Offline
*
Re: CentOS admin not loading - forgot port ?
« Reply #7 on: February 25, 2018, 06:24:59 PM »
Just an update.

I am finally able to access cwp but I am still not sure what caused it.

This time only thing I did new was that instead of
Code: [Select]
service cwpsrv restartI did :

Code: [Select]
service cwpsrv stop and then
Code: [Select]
service cwpsrv start