Author Topic: CentOS6 Upgrade  (Read 80749 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Re: CentOS6 Upgrade
« Reply #165 on: September 21, 2017, 12:18:30 AM »
Hi, I have tried to upgrade with no success. Seems that CWP did upgrade but my apache didn't do it fine. After running the script to rescue the apache I get the "Warning: SuexecUserGroup directive requires SUEXEC wrapper." error everytime httpd is started and also all my php pages show "internal server error"

Apache version: Apache/2.2.27
PHP version: 5.4.45 [PHP Switcher]
MySQL version: 5.5.56
FTP version: 1.0.36
CWP version: 0.9.8.270

I apreciate any help or guidance to resolve this

Thanks,

AJ.

Offline
*
Re: CentOS6 Upgrade
« Reply #166 on: September 21, 2017, 12:11:01 PM »
be sure that you have followed instructions and this part :

If something goes wrong with you apache try also this command
Code: [Select]
yum reinstall cwp-httpd cwp-suphp
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: CentOS6 Upgrade
« Reply #167 on: September 21, 2017, 11:37:43 PM »
Thanks for the reply. I did followed the instructions as indicated in the post, and even tried the yum reinstall command but this is what I got "
Package(s) cwp-httpd available, but not installed.
No Match for argument: cwp-suphp
Package(s) cwp-suphp available, but not installed.
Error: Nothing to do
"
I've managed to get back apache but php is down all my php pages show "Internal Serve Error" 500.

Offline
*
Re: CentOS6 Upgrade
« Reply #168 on: September 22, 2017, 12:57:30 PM »
then something failed during your upgrade

try running this one by one line
Code: [Select]
yum install cwp-httpd
yum install cwp-suphp
yum install cwp-php

sh /scripts/restart_cwpsrv
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: CentOS6 Upgrade
« Reply #169 on: September 23, 2017, 01:06:13 AM »
I have done line by line and when installing cwp_php I got this

Quote
Installing : cwp-php-5.6.30-1.i686                                        1/1
Stopping httpd: [  OK  ]
Starting httpd: httpd: Syntax error on line 419 of /usr/local/apache/conf/httpd.conf: Syntax error on line 3 of /usr/local/apache/conf.d/mod_security.conf: Cannot load modules/mod_security2.so into server: /usr/local/apache/modules/mod_security2.so: undefined symbol: ap_log_error
[FAILED]
warning: %post(cwp-php-5.6.30-1.i686) scriptlet failed, exit status 1
Non-fatal POSTIN scriptlet failure in rpm package cwp-php-5.6.30-1.i686
  Verifying  : cwp-php-5.6.30-1.i686                                        1/1

Installed:
  cwp-php.i686 0:5.6.30-1

Complete!

Offline
*
Re: CentOS6 Upgrade
« Reply #170 on: September 25, 2017, 01:20:39 PM »
oh you have 32bit system, it's recommend to have 64bit system...however, try this
rm -f /usr/local/apache/conf.d/mod_security.conf

then try to install modsecurity again if that fails then build apache & suphp from source from cwp and then again install modsecurity.
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: CentOS6 Upgrade
« Reply #171 on: October 15, 2017, 10:23:56 AM »
Hello Support,

I wanted to update the CWP version and I went ahead and upgraded the MySQL first, following below KB.

http://forum.centos-webpanel.com/centos-6-problems/centos6-upgrade/

I applied following commands.

cd /usr/local/src
wget http://dl1.centos-webpanel.com/files/el6/cwpupgrade/mysql.sh
sh mysql.sh

Code: [Select]

[root@www src]# sh mysql.sh
Loaded plugins: fastestmirror, replace
Loading mirror speeds from cached hostfile
 * base: mirror.gpmidi.net
 * extras: mirror.calgah.com
 * rpmforge: mirror.us.leaseweb.net
 * updates: centos.zswap.net
 * webtatic: us-east.repo.webtatic.com
repo id                                  repo name                                                        status
base                                     CentOS-6 - Base                                                  6706
extras                                   CentOS-6 - Extras                                                  46
rpmforge                                 RHEL 6 - RPMforge.net - dag                                      4718
updates                                  CentOS-6 - Updates                                                722
webtatic                                 Webtatic Repository EL6 - x86_64                                  362


After this MYSQL server stopped with following error.

Code: [Select]
[root@www src]# service mysqld start
MySQL Daemon failed to start.
Starting mysqld:                                           [FAILED]


I went ahead and checked the  yum history, and noticed that there are 2 versions of MySQL.

Code: [Select]

Warning: RPMDB altered outside of yum.
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
mysql55w-5.5.57-1.w6.x86_64 has installed conflicts mysql < ('0', '5.5', None): mysql-5.1.73-8.el6_8.x86_64
mysql55w-libs-5.5.57-1.w6.x86_64 has installed conflicts mysql-libs < ('0', '5.5', None): mysql-libs-5.1.73-8.el6_8.x86_64


and MySQL version shows the following output.

Code: [Select]
[root@www src]# mysql --version
mysql  Ver 14.14 Distrib 5.5.57, for Linux (x86_64) using readline 5.1


I checked the MYSQL logs and it gave following output.

Code: [Select]
171015  5:41:01 [Note] /usr/libexec/mysqld: Normal shutdown

171015  5:41:01 [Note] Event Scheduler: Killing the scheduler thread, thread id 1
171015  5:41:01 [Note] Event Scheduler: Waiting for the scheduler thread to reply
171015  5:41:01 [Note] Event Scheduler: Stopped
171015  5:41:01 [Note] Event Scheduler: Purging the queue. 1 events
171015  5:41:01  InnoDB: Starting shutdown...
171015  5:41:22  InnoDB: Shutdown completed; log sequence number 1 2391391413
171015  5:41:22 [Note] /usr/libexec/mysqld: Shutdown complete

171015 05:41:22 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended

MySQL upgrade also failed with the error.

Code: [Select]
[root@www log]# mysql_upgrade -u roor -p
Enter password:
Looking for 'mysql' as: mysql
Looking for 'mysqlcheck' as: mysqlcheck
Error: Failed while fetching Server version! Could be due to unauthorized access.
FATAL ERROR: Upgrade failed

I am stuck with the stopped MySQL serer.

Please assist.

Offline
*
Re: CentOS6 Upgrade
« Reply #172 on: December 01, 2017, 01:39:12 AM »
Solved by:
yum remove cwp-httpd
yum install cwp-httpd

Thanks! This fixed my issue with apache

Offline
*
Re: CentOS6 Upgrade
« Reply #173 on: February 22, 2018, 03:59:14 AM »
WHAT the f****


This server needs to be upgraded by using this instruction!
http://forum.centos-webpanel.com/centos-6-problems/centos6-upgrade/

For assistance, you can contact our support at:
http://centos-webpanel.com/contact

I DONT WONT UPDATE

Offline
*
Re: CentOS6 Upgrade
« Reply #174 on: February 22, 2018, 12:25:36 PM »
WHAT the f****


This server needs to be upgraded by using this instruction!
http://forum.centos-webpanel.com/centos-6-problems/centos6-upgrade/

For assistance, you can contact our support at:
http://centos-webpanel.com/contact

I DONT WONT UPDATE

As a workaround you can go to /usr/local/cwpsrv/htdocs/ and swap the 'admin' and 'admin_disabled' folder names.
Do a backup of entire htdocs before doing this

Offline
*
Re: CentOS6 Upgrade
« Reply #175 on: February 22, 2018, 01:23:01 PM »
this morning my customers started asking why they can't login to the panel and why they see a message about upgrading, this is not something to be shown to everybody, but server admin.
I have not upgraded yet due to several problems happened after i tried it some months ago and i have had to restore the server from a backup.
I also subscribed for the pro service to avoid problems like this,but it happened anyway without any previous communication.

If you are in the same boat as me and want to re-enable the cwp login, follow these instructions:

1. login to your shell
2. cd /usr/local/cwpsrv/
3. cp -r htdocs htdocs_backup
4. cd htdocs
5. mv admin admin_backup
6. mv admin_disabled admin

now you should be able to login again

if something goes wrong you can restore to the previous state by

1. rm -rf /usr/local/cwpsrv/htdocs

2. mv /usr/local/cwpsrv/htdocs_backup /usr/local/cwpsrv/htdocs

i'm not saying that users must not upgrade to new version, but at the moment it looks very dangerous doing it on a live server without having issues to be solved later.



WHAT the f****


This server needs to be upgraded by using this instruction!
http://forum.centos-webpanel.com/centos-6-problems/centos6-upgrade/

For assistance, you can contact our support at:
http://centos-webpanel.com/contact

I DONT WONT UPDATE

As a workaround you can go to /usr/local/cwpsrv/htdocs/ and swap the 'admin' and 'admin_disabled' folder names.
Do a backup of entire htdocs before doing this

Offline
*
Re: CentOS6 Upgrade
« Reply #176 on: February 22, 2018, 02:44:56 PM »
you have the notification in cwp.admin in "red alert" box more than a few months now.

You need to do this upgrade as version 0.9.8.15x is very old and has security issues which were fixed a long time ago.
Also, each cwp version has expire date so you can't run it forever as it will be unusable soon and then you will have an error and no notification about upgrade needed.
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: CentOS6 Upgrade
« Reply #177 on: February 23, 2018, 08:48:59 AM »
The problem is that the upgrade procedure doesn't work.
I had to restore the vm from a snapshopshot to rollback.
Tried on two servers a lot of time ago. I will try again when I can.

However I think it is not a right choice to disable the control panel, the servers are not yours.

you have the notification in cwp.admin in "red alert" box more than a few months now.

You need to do this upgrade as version 0.9.8.15x is very old and has security issues which were fixed a long time ago.
Also, each cwp version has expire date so you can't run it forever as it will be unusable soon and then you will have an error and no notification about upgrade needed.

Offline
*
Re: CentOS6 Upgrade
« Reply #178 on: February 23, 2018, 09:07:31 AM »
and in case that your server got hacked then you would say that this is cwp issue even you have ignored security notification for more than few months?

Anyway, it would be better to specify the exact issue and not only "upgrade procedure doesn't work", which upgrade procedure?
You have few scripts for the upgrade, which has an issue, what is the issue?

You need to specify detailed info if you want that someone can answer/assist you.
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: CentOS6 Upgrade
« Reply #179 on: February 23, 2018, 09:55:33 AM »
If the server will be hacked obviously it's my fault
If the update procedure does not work it's your fault
The update procedure is the one described on the first page of this thread
I have not reported the exact problem because I do not remember it exactly
If I will try the update again I will report the error here.
The problem is that I'm on a production server. I can not leave it offline for too long or put it offline too often