Author Topic: Error with ionCube Encoder version  (Read 3315 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Error with ionCube Encoder version
« on: June 09, 2017, 06:46:28 PM »
Hello,

I have an error 500 on CWP login page:
Quote
[Fri Jun 09 20:29:27 2017] [error] [client xxx.xxx.xxx.xxx] PHP Fatal error:  <br>The file <b>/usr/local/cwpsrv/htdocs/admin/index.php</b> was encoded with the PHP 5.6 ionCube Encoder and requires PHP 5.6 to be installed. in Unknown on line 0

How can I solve this issue?

Quote
# php -v
PHP 5.4.45 (cli) (built: Jun  9 2017 18:53:59)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v6.0.5, Copyright (c) 2002-2016, by ionCube Ltd.

Should I update my PHP version to 5.6? If yes, can you describe how?

Offline
*
Re: Error with ionCube Encoder version
« Reply #1 on: June 10, 2017, 08:30:20 AM »
yum install cwp-php
if that fails then you can use php switcher to build required version
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Error with ionCube Encoder version
« Reply #2 on: July 06, 2017, 07:11:13 AM »
yum install cwp-php
if that fails then you can use php switcher to build required version

Same issue, I installed cwp-php, and now #php -v is

Code: [Select]
PHP 5.6.30 (cli) (built: Jan 30 2017 15:28:10)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v6.0.9, Copyright (c) 2002-2016, by ionCube Ltd.

but the error log has still there, please help :(

Code: [Select]
PHP Fatal error:  <br>The file <b>/usr/local/cwpsrv/htdocs/admin/index.php</b> was encoded with the PHP 5.6 ionCube Encoder and requires PHP 5.6 to be installed. in Unknown on line 0

Offline
*
Re: Error with ionCube Encoder version
« Reply #3 on: July 06, 2017, 09:11:06 AM »
what is your cwp version, use this command to check
Code: [Select]
/scripts/cwp_version
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Error with ionCube Encoder version
« Reply #4 on: July 06, 2017, 01:48:53 PM »
what is your cwp version, use this command to check
Code: [Select]
/scripts/cwp_version

I can not check it :(

Code: [Select]
# /scripts/cwp_version
-bash: /scripts/cwp_version: Permission denied

Offline
*
Re: Error with ionCube Encoder version
« Reply #5 on: July 06, 2017, 01:53:49 PM »
But i have just installed from http://centos-webpanel.com/cwp-latest this afternoon
Its latest
« Last Edit: July 06, 2017, 02:19:04 PM by anhtn »

Offline
*
Re: Error with ionCube Encoder version
« Reply #6 on: July 06, 2017, 02:52:07 PM »
because it's urgent task, so I re-install the cwp, and now in error_log display

Code: [Select]
[emerg] 2660#0: unexpected end of file, expecting ";" or "}" in /usr/local/cwpsrv/conf.d/php.conf:3
and the cwp:

This site canít be reached
webpage refused to connect.

the #/scripts/cwp_version still dont have permission

 :'( :'( :'(

Offline
*
Re: Error with ionCube Encoder version
« Reply #7 on: July 07, 2017, 02:34:26 PM »
the best would be that you contact support since looks like you have now multiple issues
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Error with ionCube Encoder version
« Reply #8 on: August 11, 2018, 10:24:07 AM »
i get this error now, but this command yum install cwp-php doesnt help...
As for using php switcher is not good advise ... 
if your seeing this error you cant access your panel. 
if you reboot server the error goes away until i click on the"php selector" so in my case php selector is triggering the error.
so is there anyone that knows whats happening?

and please dont tell me to contact support , $7 pr visit  and/or  $12 a month is way to expensive.
« Last Edit: August 11, 2018, 10:33:54 AM by bupet »

Offline
*
Re: Error with ionCube Encoder version
« Reply #9 on: August 27, 2018, 11:19:02 AM »
I have the same problem

2018/08/27 13:14:54 [error] 6969#0: *66 FastCGI sent in stderr: "PHP message: PHP Fatal error:  <br>The encoded file <b>/usr/local/cwpsrv/htdocs/admin/index.php</b> has expired. in Unknown on line 0" while reading response header from upstream, client: 10.1.1.94, server: localhost, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "10.1.7.78:2030"

php ver 5.4.45

cwp ver permission denied

What can I do?

Offline
*****
Re: Error with ionCube Encoder version
« Reply #10 on: August 27, 2018, 02:24:49 PM »
I have the same problem

2018/08/27 13:14:54 [error] 6969#0: *66 FastCGI sent in stderr: "PHP message: PHP Fatal error:  <br>The encoded file <b>/usr/local/cwpsrv/htdocs/admin/index.php</b> has expired. in Unknown on line 0" while reading response header from upstream, client: 10.1.1.94, server: localhost, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/usr/local/cwp/php71/var/sockets/cwpsrv.sock:", host: "10.1.7.78:2030"

php ver 5.4.45

cwp ver permission denied

What can I do?

either take backup of your data and reinstall cwp7 on centos 7 or contact us via support portal for investigation and resolving the issue.