Author Topic: suPHP errors following upgrade to 0.9.8.273  (Read 878 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
suPHP errors following upgrade to 0.9.8.273
« on: January 16, 2018, 05:15:14 AM »
Following the upgrade to version 0.9.8.273, I have many of the following errors in my error_log.

Code: [Select]
[Mon Jan 15 23:02:14.126274 2018] [:error] [pid 32552:tid 140224454465280] [client xx:30240] suPHP version 0.7.2
[Mon Jan 15 23:02:14.126353 2018] [:error] [pid 32552:tid 140224454465280] [client xx:30240] (c) 2002-2007 Sebastian Marsching
[Mon Jan 15 23:02:14.126362 2018] [:error] [pid 32552:tid 140224454465280] [client xx:30240]
[Mon Jan 15 23:02:14.126377 2018] [:error] [pid 32552:tid 140224454465280] [client xx:30240] suPHP has to be called by mod_suphp to work.
[Mon Jan 15 23:02:14.126405 2018] [core:error] [pid 32552:tid 140224454465280] [client xx:30240] End of script output before headers: index.php

suphp.conf contains the following
Code: [Select]
LoadModule suphp_module modules/mod_suphp.so
<IfModule mod_suphp.c>
suPHP_Engine on
AddType application/x-httpd-php .php5 .php4 .php .php3 .php2 .phtml
<Directory />
        suPHP_AddHandler application/x-httpd-php
</Directory>
<Directory /usr/local/apache/htdocs/>
        suPHP_UserGroup nobody nobody
</Directory>
</IfModule>
suPHP_AddHandler application/x-httpd-php44
suPHP_AddHandler application/x-httpd-php52
suPHP_AddHandler application/x-httpd-php53
suPHP_AddHandler application/x-httpd-php54
suPHP_AddHandler application/x-httpd-php55
suPHP_AddHandler application/x-httpd-php56
suPHP_AddHandler application/x-httpd-php70
suPHP_AddHandler application/x-httpd-php71

Any help is appreciated.  Thanks!

Offline
*
Re: suPHP errors following upgrade to 0.9.8.273
« Reply #1 on: January 16, 2018, 03:10:08 PM »
I should mention I've already tried

Code: [Select]
yum reinstall cwp-suphp
I've also rebuilt the vhosts config, and I have tried to rebuild apache (though the 2.4.29 version that installed during the upgrade is not available in CWP; 2.4.26 is the latest version in the Apache Builder).

Also, there are no errors on httpd start.  Browsing to php pages generates a 500 error.

Offline
*
Re: suPHP errors following upgrade to 0.9.8.273
« Reply #2 on: January 16, 2018, 04:15:24 PM »
For anyone stumbling across this, I was able to fix the problem by adding

Code: [Select]
User nobody
Group nobody

to my httpd.conf file.