Author Topic: Clamav + Amavis not auto starting  (Read 1891 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Clamav + Amavis not auto starting
« on: October 10, 2017, 09:50:45 AM »
This is not a huge issue but when I do a server reboot now (Centos 7 VPS, 2 core, 4gb, 40gb, 4tb) my ClamAV, AMaViS and SpamAssassin do not auto start (little moon "asleep?" icon). They start fine when I click start for them, they are configured correctly but I'm just curious as to why they don't autostart.

Thanks in advance for any insight!

Offline
*
Re: Clamav + Amavis not auto starting
« Reply #1 on: February 21, 2018, 04:20:53 PM »
I use this after a reboot:

service clamd stop
service postfix stop
rm -f /var/run/clamd.amavisd/clamd.sock

!!!delay for 10 seconds before continuing

service postfix start
service clamd start



Offline
*
Re: Clamav + Amavis not auto starting
« Reply #2 on: November 09, 2018, 06:05:04 PM »
This is not a huge issue but when I do a server reboot now (Centos 7 VPS, 2 core, 4gb, 40gb, 4tb) my ClamAV, AMaViS and SpamAssassin do not auto start (little moon "asleep?" icon). They start fine when I click start for them, they are configured correctly but I'm just curious as to why they don't autostart.

Thanks in advance for any insight!

Reviving old post from the dead....

I also have this issue, if I start it like you  do it uses 100% CPU,  I run this after every reboot to fix:

service clamd stop
rm -f /var/run/clamd.amavisd/clamd.sock
service clamd start


Offline
*
Re: Clamav + Amavis not auto starting
« Reply #3 on: May 14, 2019, 03:43:30 PM »
Some one can help me?



● clamd.service - clamd scanner () daemon
   Loaded: loaded (/usr/lib/systemd/system/clamd.service; static; vendor preset: disabled)
   Active: failed (Result: start-limit) since Tue 2019-05-14 16:39:58 BST; 2min 26s ago

  Process: 40721 ExecStart=/usr/sbin/clamd -c /etc/clamd.d/amavisd.conf --foreground=yes (code=exited, status=1/FAILURE)
 Main PID: 40721 (code=exited, status=1/FAILURE)

May 14 16:39:58 WEB01.local systemd[1]: Unit clamd.service entered failed state.
May 14 16:39:58 WEB01.local systemd[1]: clamd.service failed.
May 14 16:39:58 WEB01.local systemd[1]: clamd.service holdoff time over, scheduling restart.
May 14 16:39:58 WEB01.local systemd[1]: Stopped clamd scanner () daemon.
May 14 16:39:58 WEB01.local systemd[1]: start request repeated too quickly for clamd.service
May 14 16:39:58 WEB01.local systemd[1]: Failed to start clamd scanner () daemon.
May 14 16:39:58 WEB01.local systemd[1]: Unit clamd.service entered failed state.
May 14 16:39:58 WEB01.local systemd[1]: clamd.service failed.

Offline
*
Re: Clamav + Amavis not auto starting
« Reply #4 on: May 15, 2019, 03:24:59 PM »
try this,
yum remove clamav -y
yum ynstall clamav -y

reboot ant test if thats work or not

Offline
*
Re: Clamav + Amavis not auto starting
« Reply #5 on: May 18, 2019, 08:27:53 PM »
I had a similar issue with spamassassin.  For me, I manually enabled it from the shell:
systemctl enable spamassassin

It's now enabled on reboot.