Author Topic: Default page appears, even though account completely set up  (Read 765 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
Default page appears, even though account completely set up
« on: March 19, 2019, 05:58:21 PM »
I have all the files for one of my accounts uploaded to the site, and the Vhost is set up.
I set my local machine to go to 192.168.1.10 (local IP of my server) for the domain name mydomain.com
However, when I visit "mydomain.com" in my browser, it gives me the CentOS default page. Why isn't it directing such traffic to the account for mydomain.com which I set up in Apache?

Matthew

PS I verified that there is only ONE index file (index.php) available -- there is no index.html or index.htm in the home directory.

.htaccess:
Code: [Select]
#<IfModule mod_suphp.c>
# suPHP_ConfigPath /home/mydomain
# <Files php.ini>
#   order allow,deny
#   deny from all
# </Files>
#</IfModule>

ErrorDocument 401 /home/mydomain/public_html/index.php
ErrorDocument 404 /home/mydomain/public_html/index.php
ErrorDocument 500 /home/mydomain/public_html/index.php
DirectoryIndex index.php index.html index.htm

AddHandler application/x-httpd-php53 .php .html .htm
RewriteEngine On
RewriteCond %{HTTP_HOST} !^www\.
RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]
# Use PHP53 as default
#AddHandler application/x-httpd-php53 .php

XSendFile on

Vhosts:
Code: [Select]
<VirtualHost 192.168.1.20:80>
        ServerName mydomain.com
        ServerAlias www.mydomain.com
        ServerAdmin webmaster@mydomain.com
        DocumentRoot /home/mydomain/public_html
        UseCanonicalName Off
        ScriptAlias /cgi-bin/ /home/mydomain/public_html/cgi-bin/

        CustomLog /usr/local/apache/domlogs/mydomain.com.bytes bytes
        CustomLog /usr/local/apache/domlogs/mydomain.com.log combined
        ErrorLog /usr/local/apache/domlogs/mydomain.com.error.log

        # Custom settings are loaded below this line (if any exist)
        # IncludeOptional "/usr/local/apache/conf/userdata/mydomain/mydomain.com/*.conf"

        <IfModule mod_setenvif.c>
                SetEnvIf X-Forwarded-Proto "^https$" HTTPS=on
        </IfModule>

        <IfModule mod_userdir.c>
                UserDir disabled
                UserDir enabled mydomain
        </IfModule>

        <IfModule mod_suexec.c>
                SuexecUserGroup mydomain mydomain
        </IfModule>

        <IfModule mod_suphp.c>
                suPHP_UserGroup mydomain mydomain
                suPHP_ConfigPath /home/mydomain
        </IfModule>

        <IfModule mod_ruid2.c>
                RMode config
                RUidGid mydomain mydomain
        </IfModule>

        <IfModule itk.c>
                AssignUserID mydomain mydomain
        </IfModule>

        <Directory "/home/mydomain/public_html">
                Options -Indexes -FollowSymLinks
                AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch
        </Directory>

</VirtualHost>
« Last Edit: March 19, 2019, 06:03:03 PM by DeveloperMcD »

Offline
*
Re: Default page appears, even though account completely set up
« Reply #1 on: March 19, 2019, 06:18:17 PM »
It may related with your vhost.
you set up IP 192.168.1.10 in ur local machine but in your Virtualhost 192.168.1.20:80

Set the appropriate shared IP in "CWP Settings" -> "Edit Setting".

Offline
**
Re: Default page appears, even though account completely set up
« Reply #2 on: March 20, 2019, 02:42:28 AM »
Sorry about that...let's just say it was a typo. The IP addresses actually match.

Any other ideas?

Offline
*
Re: Default page appears, even though account completely set up
« Reply #3 on: March 20, 2019, 04:26:27 PM »
I am having the same issue.
Already set up another Domain for test
Problem is there for each new user.
existing users are not affected
mails however work
AutoSSL does work, too
I installed all updates
I double checked the vhost files, and the vhost is the same as another domain on the server, just another user and another domain.

I am clueless.. I need help, too

may you please say how you fixed this, if you had?
« Last Edit: March 20, 2019, 04:40:39 PM by happycomputer »

Offline
**
Re: Default page appears, even though account completely set up
« Reply #4 on: March 21, 2019, 02:32:48 PM »
No, still no luck.

I have moved over 2 websites from my old CWP webserver.

One of them has the problem described above.

However, the second website works fine when I set the IP manually (in my hosts file) to use the 2nd server instead of the old, currently public facing one that my router routes all port 80 traffic to.

Same guy set both of them up -- namely, me. But I'm trying to figure out what's different between the two sites.

One uses SSL, the other doesn't.

Offline
*
Re: Default page appears, even though account completely set up
« Reply #5 on: March 21, 2019, 03:23:14 PM »
I just wanted to create a ticket for this to..
The reason for this, is that is that all requests are getting into the folder "/usr/local/apache".
And not in the folder under the username.
Just checked that a few weeks ago. Was hoping that this would have been solved, but so far this issue is still there.
« Last Edit: March 21, 2019, 03:51:47 PM by Nagataka »

Offline
*
Re: Default page appears, even though account completely set up
« Reply #6 on: March 21, 2019, 04:06:44 PM »
Alright, seems i found out the problem. (For me).
Under Webserver Settings -> Apache Rebuild, i noticed i was running. Apache 2.4.37 & suPHP 0.7.2
Just because i had some weird feeling, that there was another (hidden?) process running, i tried downgrading this to: Apache 2.4.34 & suPHP 0.7.2

Took not so long after this downgrade did finish.
Result; all my websites are working again and referring to the correct home folders.

Hope this will work for you aswell!

Offline
*
Re: Default page appears, even though account completely set up
« Reply #7 on: March 22, 2019, 12:19:03 PM »
I've tried, but no luck for me.

But I can confirm Apache 2.4.37 was active and suPHP 0.7.2

Offline
*
Re: Default page appears, even though account completely set up
« Reply #8 on: March 22, 2019, 01:01:05 PM »
I've tried, but no luck for me.

But I can confirm Apache 2.4.37 was active and suPHP 0.7.2

Not sure if it is important.
But i also changed the webserver from apache -> ngnix + apache

Offline
**
Re: Default page appears, even though account completely set up
« Reply #9 on: March 22, 2019, 09:17:24 PM »
So what is the real cause?

Do you need to rebuild Apache or maybe just the vhosts files to get things working?

Offline
*
Re: Default page appears, even though account completely set up
« Reply #10 on: March 23, 2019, 10:31:41 AM »
So what is the real cause?

Do you need to rebuild Apache or maybe just the vhosts files to get things working?

From what i have been reading in these forums. Do you maybe also have something like cwp-httpd running?