Author Topic: Just moved to CWP7 - couple issues  (Read 804 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
Just moved to CWP7 - couple issues
« on: February 19, 2017, 02:05:26 PM »
Hi All,

Just installed CWP/CentOS 7 on a fresh VPS server, switch to PHP 7.1.2. I transferred 2 sites, 1x static and 1x eCommerce (both WordPress & using Letsencrypt SSL). They look good and performance is snappy but have encountered 2 issues.

When I rebuild Postfix mail server I get the following error (interesting as emails still work)


Configuring...
Something wrong in Postfix, check log files please...



When I click Advanced File Manager I receive the following error - The file /usr/local/cwpsrv/htdocs/admin/admin/fileManager2.php is corrupted.

 
If there's an easy fix or something I'm missing please let me know otherwise I hope this helps it's development.


 :)
https://6sense.com.au
Web Design, Development & Hosting.

Offline
**
Re: Just moved to CWP7 - couple issues
« Reply #1 on: February 20, 2017, 01:40:00 AM »
I rebuild Apache and now can access Advanced File Manager although sometimes it just shows not happy faces in one or both applets instead of the file tree. Progress? lol

Rebuilding Postfix (with DKIM & SPF) still fails though email is working. Posted full output below.

Loaded plugins: fastestmirror
No Packages marked for removal
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.web-ster.com
 * epel: mirror.sfo12.us.leaseweb.net
 * extras: mirror.web-ster.com
 * updates: mirror.web-ster.com
No package clamd available.
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.web-ster.com
 * epel: mirror.sfo12.us.leaseweb.net
 * extras: mirror.web-ster.com
 * updates: mirror.web-ster.com
Package opendkim-2.11.0-0.1.el7.x86_64 already installed and latest version
Package libopendkim-2.11.0-0.1.el7.x86_64 already installed and latest version
Package perl-Mail-DKIM-0.39-8.el7.noarch already installed and latest version
Package perl-Mail-SPF-2.8.0-4.el7.noarch already installed and latest version
Package pypolicyd-spf-1.3.2-1.el7.noarch already installed and latest version
No package clamd available.
Nothing to do
Configuring...
Something wrong in Postfix, check log files please...
https://6sense.com.au
Web Design, Development & Hosting.

Offline
*
Re: Just moved to CWP7 - couple issues
« Reply #2 on: February 20, 2017, 02:58:31 AM »
I had same problem with advanced file manager - its a bug, ran /scripts/update_cwp and that fixed the problem, hope that helps.

Offline
**
Re: Just moved to CWP7 - couple issues
« Reply #3 on: February 20, 2017, 04:30:38 AM »
Thanks Indigo, I think that has sorted the Advanced File Manager issue ( I just noticed the new File Manager button at the top of dashboard too. Nice stuff!   :D

Now I just have the Postfix rebuild error as below. I've run email tests eg: DKIM, SPF and everything passes just can't get Postfix to rebuild without the error. I've looked in /var/log/maillog (now that file manager working) but TBH am not sure what I'm looking for in there.

Postfix error:

Configuring...
Something wrong in Postfix, check log files please...

https://6sense.com.au
Web Design, Development & Hosting.