Author Topic: AutoSSL not adding on www  (Read 492 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
AutoSSL not adding on www
« on: December 14, 2018, 10:26:47 AM »
I recently have transferred my domain to CWP and I am getting error .. NET::ERR_CERT_COMMON_NAME_INVALID

My domain is https://www.pgrepublic.com

Offline
***
Re: AutoSSL not adding on www
« Reply #1 on: December 14, 2018, 01:29:49 PM »
I could see that SSL is properly installed on your website https://www.sslshopper.com/ssl-checker.html#hostname=pgrepublic.com

Are you using apache or any other webserver?

Try to restart apache to see the affect.

Offline
*
Re: AutoSSL not adding on www
« Reply #2 on: December 14, 2018, 01:38:44 PM »
I recently have transferred my domain to CWP and I am getting error .. NET::ERR_CERT_COMMON_NAME_INVALID

My domain is https://www.pgrepublic.com

If your htaccess redirect to www try to remove www and redirect to https://pgrepublic.com

Or simply add redirect on vhost :

Code: [Select]
<VirtualHost *:80>
ServerName www.example.com
Redirect / https://example.com/ <== add this line below ServerName
</VirtualHost>
« Last Edit: December 14, 2018, 01:51:59 PM by randyproxz »

Offline
*
Re: AutoSSL not adding on www
« Reply #3 on: December 14, 2018, 02:16:39 PM »
I could see that SSL is properly installed on your website https://www.sslshopper.com/ssl-checker.html#hostname=pgrepublic.com

Are you using apache or any other webserver?

Try to restart apache to see the affect.

Yes I restarted the apache, even restarted whole server couple of times. No effect

Offline
*
Re: AutoSSL not adding on www
« Reply #4 on: December 14, 2018, 02:20:41 PM »
I recently have transferred my domain to CWP and I am getting error .. NET::ERR_CERT_COMMON_NAME_INVALID

My domain is https://www.pgrepublic.com

If your htaccess redirect to www try to remove www and redirect to https://pgrepublic.com

Or simply add redirect on vhost :

Code: [Select]
<VirtualHost *:80>
ServerName www.example.com
Redirect / https://example.com/ <== add this line below ServerName
</VirtualHost>


I can try that, but this is not the solution to the problem. AutoSSL should generate for both pgrepublic.com and www.pgrepublic.com. Other thing is SEO and bank links which I am afraid of

Offline
*
Re: AutoSSL not adding on www
« Reply #5 on: December 14, 2018, 02:32:08 PM »
I could see that SSL is properly installed on your website https://www.sslshopper.com/ssl-checker.html#hostname=pgrepublic.com

Are you using apache or any other webserver?

Try to restart apache to see the affect.

if you check https://www.sslshopper.com/ssl-checker.html#hostname=www.pgrepublic.com you will notice "None of the common names in the certificate match the name that was entered (www.pgrepublic.com). You may receive an error when accessing this site in a web browser."

Offline
*
Re: AutoSSL not adding on www
« Reply #6 on: December 14, 2018, 03:03:38 PM »
You must remove the redirect from http to https before generating the Auto ssl, then you could place it again

Offline
*
Re: AutoSSL not adding on www
« Reply #7 on: December 14, 2018, 03:26:12 PM »
You must remove the redirect from http to https before generating the Auto ssl, then you could place it again

Thanks @josemnunez, that was the issue.

For any one coming here or future me.

If wordpress is hosted on HTTPS first and then moved to CWP. need to change `siteurl` and `home` values to be without https in `wp_options` table. This will stop the redirect to https. Then generate the certificate.

It does solve my problem