Author Topic: Bug Error?  (Read 3978 times)

0 Members and 1 Guest are viewing this topic.

Offline
***
Bug Error?
« on: October 11, 2016, 10:25:34 PM »
Hi, i enter to phpmyadmin and i said that:

Code: [Select]
Deprecation Notice in ./libraries/php-gettext/streams.php#48
Methods with the same name as their class will not be constructors in a future version of PHP; StringReader has a deprecated constructor

Backtrace

./libraries/php-gettext/gettext.inc#41: require()
./libraries/select_lang.lib.php#471: require_once(./libraries/php-gettext/gettext.inc)
./libraries/common.inc.php#564: require(./libraries/select_lang.lib.php)
./navigation.php#10: require_once(./libraries/common.inc.php)
Deprecation Notice in ./libraries/php-gettext/streams.php#84
Methods with the same name as their class will not be constructors in a future version of PHP; FileReader has a deprecated constructor

Backtrace

./libraries/php-gettext/gettext.inc#41: require()
./libraries/select_lang.lib.php#471: require_once(./libraries/php-gettext/gettext.inc)
./libraries/common.inc.php#564: require(./libraries/select_lang.lib.php)
./navigation.php#10: require_once(./libraries/common.inc.php)
Deprecation Notice in ./libraries/php-gettext/streams.php#145
Methods with the same name as their class will not be constructors in a future version of PHP; CachedFileReader has a deprecated constructor

Backtrace

./libraries/php-gettext/gettext.inc#41: require()
./libraries/select_lang.lib.php#471: require_once(./libraries/php-gettext/gettext.inc)
./libraries/common.inc.php#564: require(./libraries/select_lang.lib.php)
./navigation.php#10: require_once(./libraries/common.inc.php)
Deprecation Notice in ./libraries/php-gettext/gettext.php#36
Methods with the same name as their class will not be constructors in a future version of PHP; gettext_reader has a deprecated constructor

Backtrace

./libraries/php-gettext/gettext.inc#42: require()
./libraries/select_lang.lib.php#471: require_once(./libraries/php-gettext/gettext.inc)
./libraries/common.inc.php#564: require(./libraries/select_lang.lib.php)
./navigation.php#10: require_once(./libraries/common.inc.php)

php 7.0.11
maria db last version
apache 2.2.31

Offline
*****
Re: Bug Error?
« Reply #1 on: October 28, 2016, 11:42:47 AM »
Hello.

Seems like PhpMyAdmin does not support PHP 7 yet.
Check documentation: https://docs.phpmyadmin.net/en/latest/require.html#php
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
***
Re: Bug Error?
« Reply #2 on: October 31, 2016, 02:47:23 PM »
Hello.

Seems like PhpMyAdmin does not support PHP 7 yet.
Check documentation: https://docs.phpmyadmin.net/en/latest/require.html#php

mmm i dont think, i install php 7.0.12 and work fine with other server.

Offline
*****
Re: Bug Error?
« Reply #3 on: November 01, 2016, 09:27:07 AM »
I do not see any other errors in your "trace".
Try upgrade PMA to latest version (do not forget about config copy).
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services