Author Topic: BUG sur chaque comptes creé  (Read 3504 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
BUG sur chaque comptes creé
« on: October 21, 2015, 06:32:29 PM »
Bonjour,hello

Je viens ici pour vous demandez de l 'aides sa fait plusieurs jours que je tente de pouvoir enfin utilisé cwp comme je les déjà fait avec une autre version de cwp sur Centos 6.5 et la version de cwp Version 0.9.8
la j’utilise donc Centos6.7 avec la dernier version le soucie et présent avec deux serveur différent   
 
Mon problème je n'arrive pas a accéder a la page de test index.html du compte crée avec le domaine  www.domaine.eu
je tombe directement sur la page test du dossier /usr/local/apache/htdocs/index.html la ou il y a phpmyadmin,roundcube,web_ftpsimple

et non sur la page test qui ce trouve dans le dossier  /home/comptecwp/public_html/index.html :'( :'(

et le soucie et présent avec chaque domaine et compte crée  :'( :'(

j'arrive a accéder au dossier part ftp sa fonctionne nickel   :D :D

la redirection de domaine fonctionne puisque je tombe sur mon serveur  :D :D

le serveur et connecté a la freebox avec une ip dmz  :D :D


comment je peut résoudre le problème je doit pas être le seul dans cette situation merci de votre aides   

Offline
*
Re: BUG sur chaque comptes creé
« Reply #1 on: October 23, 2015, 09:25:08 AM »
Bonjour, le probleme doit venir avec le fichier host. il faut changer la template du fichier host j'ai eu le même probleme

Offline
*
Re: BUG sur chaque comptes creé
« Reply #2 on: October 31, 2015, 01:54:45 PM »
ces bien un bug du a cwp-panel puisque j'ai installé sentora et tous ces bien passé tous fonctionne normalement donc je comprend pas que un bug de cette envergure soit pas vite résolue encore tenté de l installe cette aprem mais rien que dalle 

si une personne a une réponse a mon soucie je suis preneur a savoir que j'ai bien  regarde sur le forum il y a un topic sur le soucie mais rien tous les info donne rien chez alors je viens comprendre que le soucie et souvent entre la machine et l'homme mais la je séché grave



Offline
*
Re: BUG sur chaque comptes creé
« Reply #3 on: October 31, 2015, 02:13:37 PM »
voila mais Apache virtual host template je trouve rien anormale

Apache Domain Virtual Host tpl:

# vhost_start %domain_name%
<VirtualHost %domain_ip%:%domain_port%>
ServerName %domain_name%
ServerAlias www.%domain_name%
ServerAdmin %admin_email%
DocumentRoot "%homedir%/%username%/public_html"
ScriptAlias /cgi-bin/ "%homedir%/%username%/public_html/cgi-bin/
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/%username%/%domain_name%/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup %username% %username%
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup %username% %username%
        suPHP_ConfigPath /home/%username%
</IfModule>

<Directory "%homedir%/%username%/public_html">


Apache SubDomain Virtual Host tpl:


# vhost_start %domain_name%
<VirtualHost %domain_ip%:%domain_port%>
ServerName %domain_name%
ServerAlias www.%domain_name%
ServerAdmin %admin_email%
DocumentRoot "%path%"
ScriptAlias /cgi-bin/ %path%/cgi-bin/
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/%username%/%domain_name%/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup %username% %username%
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup %username% %username%
</IfModule>

<Directory "%path%">
        AllowOverride All
</Directory>

</VirtualHost>
# vhost_end %domain_name%

Offline
*
Re: BUG sur chaque comptes creé
« Reply #4 on: November 08, 2015, 04:09:13 PM »
J,ai enfin trouve la solutions pour résoudre le problème de pointage de domaine comme dit plus haut le soucie été que je pouvez pas accéder ou domaine je reste toujours sur la page part Défaut sur tous les domaine

1*aller sur la page    /index.php?module=file_editor&file=/usr/local/apache/conf/httpd.conf

Commenté

DocumentRoot "/usr/local/apache/htdocs"    no >:(
#DocumentRoot "/usr/local/apache/htdocs"  yes ;D

Decommenté

#Include conf/extra/httpd-vhosts.conf >:(
Include conf/extra/httpd-vhosts.conf ;D

2*a prêt il faut aller sur la page  /index.php?module=file_editor&file=/usr/local/apache/conf.d/vhosts.conf

Remplacer <VirtualHost 192.168.0.0:80>

Par  <VirtualHost *:80> sur tous les domaine

RESTART APACHE ET LA MIRACLE SA REMARCHE

Juste petit message au redémarrage de apache qui dit


Stopping httpd: [  OK  ]
Starting httpd: Warning: DocumentRoot [/usr/local/apache/docs/dummy-host.example.com] does not exist
Warning: DocumentRoot [/usr/local/apache/docs/dummy-host2.example.com] does not exist
[  OK  ]

« Last Edit: November 08, 2015, 04:11:04 PM by f7hd »