Author Topic: php Switcher does not work  (Read 167 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
php Switcher does not work
« on: April 30, 2018, 02:25:02 AM »
Another bug - it just plain doesn't work.

Can't change to different version of php yet when you click on build you get a message that it's already working in the background.

You can go Pro but why pay for a software product that has so many bugs and issues?

Even tech support that you pay for tells you to go figure it out yourself.

waste of time, really

Offline
*
Re: php Switcher does not work
« Reply #1 on: May 24, 2018, 12:54:47 PM »
Hello admin,

I'm a Pro user and I confirm that PHP Selector doesn't work using the described method at: http://forum.centos-webpanel.com/php/php-selector/ since the changes aren't even saved in .htacces file after clicking the "Save" button.
Would you please fix it so that we can IN FACT change the php version for the desired domain!? And yet better off by selecting the desired domain from a list of domains (e.g. from drop_down menu, just like it's done in cPanel) instead of manually modifying .htaccess file in the domain folder. After all you've built a control panel and things should work be possible to manage from control panel.

Offline
*
Re: php Switcher does not work
« Reply #2 on: May 24, 2018, 06:03:55 PM »
I was having problems with compiling for php7 versions. The flags were set wrong. Mostly fixed by setting:
Code: [Select]
./configure
--prefix=/opt/alt/php72/usr
--with-config-file-path=/opt/alt/php72/usr/php
--with-config-file-scan-dir=/opt/alt/php72/usr/php/php.d
--enable-fpm
--enable-mbstring
--enable-zip
--enable-bcmath
--enable-pcntl
--enable-phar
--enable-ftp
--enable-exif
--enable-calendar
--enable-ffmpeg
--enable-intl
--enable-ldap
--enable-mcrypt
--enable-sysvmsg
--enable-sysvsem
--enable-sysvshm
--enable-wddx
--with-ldap
--with-intl
--with-imap
--with-imap-ssl
--with-ffmpeg
--with-curl
--with-iconv
--with-pgsql
--with-mysql
--with-mysqli
--with-mysql=mysqlnd
--with-mysqli=mysqlnd
--with-mcrypt
--with-gmp
--with-pspell
--with-gd
--with-jpeg-dir=/usr
--with-png-dir=/usr
--with-zlib-dir=/usr
--with-xpm-dir=/usr
--with-freetype-dir=/usr
--enable-gd-native-ttf
--enable-gd-jis-conv
--with-openssl
--with-pdo-mysql=/usr
--with-gettext=/usr
--with-zlib=/usr
--with-bz2=/usr
--enable-soap
--enable-phar
--with-xsl
--with-xmlrpc
--with-kerberos
--enable-posix
--enable-sockets
--with-pcre-regex
--enable-calendar
--with-libdir=lib64
--with-mysql-sock=/var/lib/mysql/mysql.sock


The big change for me was making --with-libdir=/usr/lib64 to --with-libdir=lib64

Also, the first try for version 7.2 it barked at me for imap (though I thought I had it already). Fixed that by yum install php-imap

Offline
*
Re: php Switcher does not work
« Reply #3 on: May 25, 2018, 12:22:17 PM »
as you all certainly know cwp website has a contact form where you can report any issue and they also resolve it fast when reported, mostly on the same day.
http://centos-webpanel.com/contact

also don't forget to check your log files
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: php Switcher does not work
« Reply #4 on: May 25, 2018, 05:22:19 PM »
Just users trying to help other users on the forum here. Thank you for not saying anything whatsoever about the issue the OP posted. The contact form will always be appreciated. However, information sent there is not a shared to the benefit of others, is it? Or maybe I am misunderstanding the purpose of Internet forums.

In any case, hopefully the OP got it resolved.