Author Topic: PHP Version Switcher Crashes With IONCUBE Across All Builds  (Read 244 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
To Administrator,

I am a CWP7pro.admin user holding two paid ips, I love this project and I love the software, it is IDEAL, however, having said that,
I am having an issue with PHP Version Selector. Regardless of the build I choose, be it 5.2, 5.3,5.4,5.5,5.6,7.0,7.1 or 7.2 IF you check IONCUBE box at build you will receive this error and unfortunately I happen to know that users such as myself have been reporting this as a COMMON issue, since 2017!

'ioncube_loader_lin_5.4.so' -> '/usr/local/ioncube/ioncube_loader_lin_5.4.so'
'ioncube_loader_lin_5.4_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_5.4_ts.so'
'ioncube_loader_lin_5.5.so' -> '/usr/local/ioncube/ioncube_loader_lin_5.5.so'
'ioncube_loader_lin_5.5_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_5.5_ts.so'
'ioncube_loader_lin_5.6.so' -> '/usr/local/ioncube/ioncube_loader_lin_5.6.so'
'ioncube_loader_lin_5.6_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_5.6_ts.so'
'ioncube_loader_lin_7.0.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.0.so'
'ioncube_loader_lin_7.0_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.0_ts.so'
'loader-wizard.php' -> '/usr/local/ioncube/loader-wizard.php'
yes: standard output: Broken pipe
yes: write error


Is there any possibility, you could fix this in the next update for Everybody. Most users end up reinstalling the entire server just to get it back to the way it was from fresh install never to attempt building a new PHP version again. It is VERY annoying.

I appeal to you to PLEASE, Please, correct this issue for myself and everyone else whom also LOVES Centos Web Panel!

Darren
« Last Edit: July 19, 2018, 03:40:47 PM by stuffnotworking »

Offline
*
Re: PHP Version Switcher Crashes With IONCUBE Across All Builds
« Reply #1 on: July 19, 2018, 05:55:45 PM »
you should report it here as then it would be resolved for sure
centos-webpanel.com/contact
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
**
Re: PHP Version Switcher Crashes With IONCUBE Across All Builds
« Reply #2 on: July 20, 2018, 12:20:39 PM »
Don't check ioncube loader in the PHP Switcher but instead install it with the PHP Addons under PHP Settings.

Offline
*
Re: PHP Version Switcher Crashes With IONCUBE Across All Builds
« Reply #3 on: July 20, 2018, 01:47:39 PM »
Monkey King


That would obviously correct the issue, thank you for the heads up, I had not seen the Php Add on fix feature!

Excellent

Thank YOU!!!