Author Topic: Segmentation fault caused by ZendGuardLoader.so  (Read 352 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Segmentation fault caused by ZendGuardLoader.so
« on: September 18, 2017, 12:59:50 PM »
It seems, after recompiling using PHP Version Switcher v2, the command line (CLI) version of PHP starts triggering this error:

Code: [Select]
PHP 5.6.31 (cli) (built: Sep 18 2017 00:20:10)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend Guard Loader v3.3, Copyright (c) 1998-2015, by Zend Technologies

Segmentation fault

Caused by ZendGuardLoader.so called in /usr/local/php/php.d/zend.ini

Any ideas why?

Offline
*
Re: Segmentation fault caused by ZendGuardLoader.so
« Reply #1 on: September 18, 2017, 07:31:48 PM »
Somehow, the PHP Version Switcher re-build created a wrong entry.

Affected file: /usr/local/php/php.d/zend.ini

Code that causes "segmentation fault" error:
Code: [Select]
extension=/usr/local/zend/5.6/ZendGuardLoader.so
Corrected code (no error)
Code: [Select]
zend_extension=/usr/local/zend/5.6/ZendGuardLoader.so
FYI

Offline
*****
Re: Segmentation fault caused by ZendGuardLoader.so
« Reply #2 on: September 21, 2017, 01:20:13 PM »
We'll update it thanks for reporting.