Author Topic: no signing table match for CWP hostname  (Read 441 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
no signing table match for CWP hostname
« on: September 13, 2019, 11:59:40 PM »
Code: [Select]
● opendkim.service - DomainKeys Identified Mail (DKIM) Milter
   Loaded: loaded (/usr/lib/systemd/system/opendkim.service; enabled; vendor preset: disabled)
   Active: active (running) since Wed 2019-09-11 07:28:31 EDT; 1 day 15h ago
     Docs: man:opendkim(8)
           man:opendkim.conf(5)
           man:opendkim-genkey(8)
           man:opendkim-genzone(8)
           man:opendkim-testadsp(8)
           man:opendkim-testkey
           http://www.opendkim.org/docs.html
 Main PID: 2545 (opendkim)
   CGroup: /system.slice/opendkim.service
           ├─2545 /usr/sbin/opendkim -x /etc/opendkim.conf -P /var/run/opendkim/opendkim.pid
           └─2546 /usr/sbin/opendkim -x /etc/opendkim.conf -P /var/run/opendkim/opendkim.pid

Sep 12 22:45:01 argon11.example.com opendkim[2546]: 4D0F83256B: no signing table match for 'root@argon11.example.com'
Sep 12 22:45:01 argon11.example.com opendkim[2546]: 4D0F83256B: no signature data
Sep 12 22:45:01 argon11.example.com opendkim[2546]: 4E60C3257B: no signing table match for 'root@argon11.example.com'
Sep 12 22:45:01 argon11.example.com opendkim[2546]: 4E60C3257B: no signature data
Sep 12 22:45:01 argon11.example.com opendkim[2546]: 4F7AF3258A: no signing table match for 'root@argon11.example.com'
Sep 12 22:45:01 argon11.example.com opendkim[2546]: 4F7AF3258A: no signature data
Sep 12 22:45:01 argon11.example.com opendkim[2546]: 5080C325A5: no signing table match for 'root@argon11.example.com'
Sep 12 22:45:01 argon11.example.com opendkim[2546]: 5080C325A5: no signature data
Sep 12 22:45:01 argon11.example.com opendkim[2546]: 519C6325A6: no signing table match for 'root@argon11.example.com'
Sep 12 22:45:01 argon11.example.com opendkim[2546]: 519C6325A6: no signature data

I ran into this while I was trying to get SSL working properly in email. The one thing I have done is change the "/etc/postfix/main.cf" file to read like this on the bottom two lines.

Quote
smtpd_tls_CAfile = /etc/pki/tls/certs/argon11.example.com.bundle
smtp_tls_CAfile = "/etc/pki/tls/certs/argon11.example.com.bundle"

There were no entries in /etc/dovecot/dovecot.conf so I did not change anything... Though I digress this should have nothing to do with the errors in the signing table and no signature data.

Can someone help me find this bug as it is constantly writing errors in the log and I don't know what other things it might be affecting.