Author Topic: bug with DKIM record append  (Read 2003 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
bug with DKIM record append
« on: January 05, 2016, 06:32:11 AM »
If I append new DKIM record in the admin area the new record is broken (vim with :set list):

Code: [Select]
; Add additional settings below this linedefault._domainkey 14400 IN TXT "v=DKIM1; k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQCaJKTJvtbkUfGopmttOJc/9KcHOhpu000iPYzeBscEdHFWbCUM+9kFGPxkq8CxFLDWlyzPKbdhWz8eKNy39JlSDOzM6e+yZfLmZ7QBuoMuycAVP2/5wVf15QrhRYk7K9jdTzuXGHoHJnlXYOxECKufHD8uIorHhkYADHura5RvjwIDAQAB"$
The problem is there no new line after the ; Add additional settings below this line or before the new DKIM record. If I append new record everything looks like normal:

Code: [Select]
; Add additional settings below this linedefault._domainkey 14400 IN TXT "v=DKIM1; k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQCaJKTJvtbkUfGopmttOJc/9KcHOhpu000iPYzeBscEdHFWbCUM+9kFGPxkq8CxFLDWlyzPKbdhWz8eKNy39JlSDOzM6e+yZfLmZ7QBuoMuycAVP2/5wVf15QrhRYk7K9jdTzuXGHoHJnlXYOxECKufHD8uIorHhkYADHura5RvjwIDAQAB"$
$
test     14400   IN      A       A.B.C.D^I; #subdomain test$
“Would you tell me, please, which way I ought to go from here?”
“That depends a good deal on where you want to get to,” said the Cat.
“I don’t much care where–” said Alice.
“Then it doesn’t matter which way you go,” said the Cat.
Neo2SHYAlien's Blog

Offline
*
Re: bug with DKIM record append
« Reply #1 on: January 05, 2016, 05:09:19 PM »
Nothing new here. This is a long standing bug reported earlier and still waiting when this would be fixed. For now, goto the DNS record and manually enter the new line as everybody else does  :-\