Author Topic: BIND wont start  (Read 16240 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
BIND wont start
« on: January 17, 2014, 08:13:33 PM »
I set the nameserver IPs etcas per instructions but BIND wont start get the following:-

Starting named:
Error in named configuration:
zone localhost.localdomain/IN: loaded serial 0
zone localhost/IN: loaded serial 0
zone 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: loaded serial 0
zone 1.0.0.127.in-addr.arpa/IN: loaded serial 0
zone 0.in-addr.arpa/IN: loaded serial 0
zone xxx.co.uk/IN: NS 'ns1.xxx.co.uk' has no address records (A or AAAA)
zone xxx.co.uk/IN: NS 'ns2.xxx.co.uk' has no address records (A or AAAA)
zone xxx.co.uk.uk/IN: not loaded due to errors.
_default/xxx.co.uk/IN: bad zone
[FAILED]

Zone file is this

; Panel %version%
; Zone file for xxx.co.uk
$TTL 14400
xxx.co.uk.      86400   IN      SOA     ns1.xxx.co.uk. email@email.co.uk. (
      2013071600   ; serial, todays date+todays
      86400      ; refresh, seconds
      7200      ; retry, seconds
      3600000      ; expire, seconds
      86400 )      ; minimum, seconds

xxx.co.uk. 86400 IN NS ns1.xxx.co.uk.
xxx.co.uk. 86400 IN NS ns2.xxx.co.uk.

xxx.co.uk. IN A 107.161.xxx.xxx

localhost.xxx.co.uk. IN A 127.0.0.1

xxx.co.uk. IN MX 0 xxx.co.uk.

mail IN CNAME xxx.co.uk.
www IN CNAME xxx.co.uk.
ftp IN CNAME xxx.co.uk.
; Add additional settings below this line

i figured adding the ip and nameserver via the panel would populate the ns1.xxx.co.uk IN A 107.161.xxx.xxx bit but hasnt in this instance it didnt like being manually added, any ideas?
« Last Edit: January 17, 2014, 08:15:27 PM by oneorzero »

Offline
*
Re: BIND wont start
« Reply #1 on: January 17, 2014, 08:41:58 PM »
got it working by adding ns1 IN A 107.158.xxx.xxx and ns2. IN A 107.158.xxx.xxx

Figured it was worth leaving the post up in case anyone else had this issue and for the developers to have a look at

Offline
*
Re: BIND wont start
« Reply #2 on: March 17, 2014, 09:21:12 AM »
yes, me too,

I got this issue too

Starting named:
Error in named configuration:
zone localhost.localdomain/IN: loaded serial 0
zone localhost/IN: loaded serial 0
zone 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: loaded serial 0
zone 1.0.0.127.in-addr.arpa/IN: loaded serial 0
zone 0.in-addr.arpa/IN: loaded serial 0
zone resepseru.com/IN: NS 'ns1.resepseru.com' has no address records (A or AAAA)
zone resepseru.com/IN: NS 'ns2.resepseru.com' has no address records (A or AAAA)
zone resepseru.com/IN: not loaded due to errors.
_default/resepseru.com/IN: bad zone
[FAILED]


and the zone file is

; Panel %version%
; Zone file for resepseru.com
$TTL 14400
resepseru.com.      86400   IN      SOA     ns1.resepseru.com. admin@tamaciptahosting.com. (
      2013071600   ; serial, todays date+todays
      86400      ; refresh, seconds
      7200      ; retry, seconds
      3600000      ; expire, seconds
      86400 )      ; minimum, seconds

resepseru.com. 86400 IN NS ns1.resepseru.com.
resepseru.com. 86400 IN NS ns2.resepseru.com.

resepseru.com. IN A 107.161.81.239

localhost.resepseru.com. IN A 127.0.0.1

resepseru.com. IN MX 0 resepseru.com.

mail IN CNAME resepseru.com.
www IN CNAME resepseru.com.
ftp IN CNAME resepseru.com.
; Add additional settings below this line


@oneorzero
where exactly i must adding ns1 in A.
in the domain control panel or else?

Thanks all, and need your help
There are things known and there are things unknown, in between are The Doors.

Offline
*
Re: BIND wont start
« Reply #3 on: March 23, 2014, 11:11:05 AM »
After finding on the net gladly it solve,

There are things known and there are things unknown, in between are The Doors.

Offline
*
Re: BIND wont start
« Reply #4 on: March 27, 2014, 07:17:43 PM »
nameserver entry's  are always needed, and if any bugs you can search with google like for standard CentOS installation.
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: BIND wont start
« Reply #5 on: May 17, 2014, 02:27:18 PM »
I am still getting the same error how do i fix this?

Offline
*
Re: BIND wont start
« Reply #6 on: May 17, 2014, 02:46:07 PM »
ty oneorzero works now!

Offline
*
Re: BIND wont start
« Reply #7 on: August 24, 2014, 06:11:19 AM »
nameserver entry's  are always needed, and if any bugs you can search with google like for standard CentOS installation.
bro,could you pleace explain the trick to solve it? using panel in domain manager or in centos web panel? tq

Offline
*
Re: BIND wont start
« Reply #8 on: August 24, 2014, 11:39:13 PM »
you need to check what is your error message.
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: BIND wont start
« Reply #9 on: December 13, 2014, 11:51:26 AM »
Stopping named: [  OK  ]
Starting named:
Error in named configuration:
/etc/named.conf:62: unexpected end of input
[FAILED]
==========================================
/etc/named.conf
==========================================

// named.rfc1912.zones:
//
// Provided by Red Hat caching-nameserver package
//
// ISC BIND named zone configuration for zones recommended by
// RFC 1912 section 4.1 : any TLDs and address zones
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//
zone "." IN {
   type hint;
   file "named.ca";
};

zone "localdomain" IN {
   type master;
   file "localdomain.zone";
   allow-update { none; };
};

zone "any" IN {
   type master;
   file "any.zone";
   allow-update { none; };
};

zone "0.0.127.in-addr.arpa" IN {
   type master;
   file "named.local";
   allow-update { none; };
};

zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa" IN {
        type master;
   file "named.ip6.local";
   allow-update { none; };
};

zone "255.in-addr.arpa" IN {
   type master;
   file "named.broadcast";
   allow-update { none; };
};

zone "0.in-addr.arpa" IN {
   type master;
   file "named.zero";
   allow-update { none; };
};


// zone netmkd.com
zone "netmkd.com" {
                                   type master;
                                        file "/var/named/netmkd.com.db";};
// zone_end netmkd.com

// zone geunet.com
zone "geunet.com" {
                                   type master;
                                        file "/var/named/geunet.com.db";};
// zone_end geunet.com



How to FIX ???

Offline
*
Re: BIND wont start
« Reply #10 on: December 15, 2014, 02:07:09 AM »
you should check your line number 62. in /etc/named.conf

/etc/named.conf:62: unexpected end of input
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: BIND wont start
« Reply #11 on: January 06, 2015, 02:47:06 PM »
change @ with a . --> this is sloved for me  :)

Offline
*
Re: BIND wont start
« Reply #12 on: January 19, 2015, 03:21:56 PM »
Still wont start .. help me ..
-----------------------------
Stopping named: [  OK  ]
Starting named:
Error in named configuration:
zone localhost.localdomain/IN: loaded serial 0
zone localhost/IN: loaded serial 0
zone 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: loaded serial 0
zone 1.0.0.127.in-addr.arpa/IN: loaded serial 0
zone 0.in-addr.arpa/IN: loaded serial 0
dns_rdata_fromtext: /var/named/mydomain.net.db:4: near 'mydomain@gmail.com.': bad name (check-names)
/var/named/mydomain.net.db:27: file does not end with newline
zone mydomain.net/IN: loading from master file /var/named/mydomain.net.db failed: bad name (check-names)
zone mydomain.net/IN: not loaded due to errors.
_default/mydomain.net/IN: bad name (check-names)
[FAILED]
« Last Edit: January 19, 2015, 03:24:09 PM by zen »

Re: BIND wont start
« Reply #13 on: January 30, 2015, 10:41:58 PM »
change mydomain@gmail.com to mydomain.gmail.com